aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit789f7e9a3d37135d22d0a84c987fe3877131fd06 (patch)
treee5ecd3aeafbbdabc7afb353dbf176eb3bc9af6ae /gnu
parenta879385de12e9bbfe90b39e14733ab261e88c171 (diff)
downloadguix-789f7e9a3d37135d22d0a84c987fe3877131fd06.tar
guix-789f7e9a3d37135d22d0a84c987fe3877131fd06.tar.gz
gnu: fuse@3: Bind to default FUSE variable.
* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm2
-rw-r--r--gnu/packages/android.scm2
-rw-r--r--gnu/packages/backup.scm2
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/bootloaders.scm4
-rw-r--r--gnu/packages/build-tools.scm2
-rw-r--r--gnu/packages/crypto.scm4
-rw-r--r--gnu/packages/file-systems.scm28
-rw-r--r--gnu/packages/freedesktop.scm2
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/kde.scm2
-rw-r--r--gnu/packages/libusb.scm2
-rw-r--r--gnu/packages/linux.scm30
-rw-r--r--gnu/packages/package-management.scm4
-rw-r--r--gnu/packages/python-xyz.scm16
-rw-r--r--gnu/packages/storage.scm2
-rw-r--r--gnu/packages/sync.scm2
-rw-r--r--gnu/packages/virtualization.scm4
-rw-r--r--gnu/system.scm2
19 files changed, 56 insertions, 58 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ec32041055..f601b8a8b4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2980,7 +2980,7 @@ modules and plugins that extend Ansible.")
(inputs
(list ansible
encfs
- fuse
+ fuse-2
util-linux ;; for umount
findutils
gnupg
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index b9b8b89208..32c295f9e4 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1291,7 +1291,7 @@ Java bytecode, which simplifies the analysis of Android applications.")
(build-system cmake-build-system)
(arguments
(list #:tests? #f)) ;there are no tests
- (inputs (list qtbase-5 fuse-3 libxkbcommon))
+ (inputs (list qtbase-5 fuse libxkbcommon))
(native-inputs (list qttools-5 openssl readline))
(home-page "https://whoozle.github.io/android-file-transfer-linux/")
(synopsis "MTP client for Android devices")
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index c8a1b388de..d484c34826 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -780,7 +780,7 @@ backups on untrusted computers.")
(native-inputs
(list pkg-config))
(inputs
- (list fuse-3 libxml2 ntfs-3g openssl))
+ (list fuse libxml2 ntfs-3g openssl))
(arguments
`(#:configure-flags
(list "--disable-static"
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 864c200707..34e8565788 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8713,7 +8713,7 @@ unique transcripts.")
(list ngs-sdk
ncbi-vdb
file
- fuse
+ fuse-2
hdf5-1.10
libxml2
zlib
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 38eb1d104f..069d02b52c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -215,8 +215,8 @@
;; file system will be readable by GRUB without rebooting.
,@(if (member (or (%current-target-system)
(%current-system))
- (package-supported-systems fuse))
- `(("fuse" ,fuse))
+ (package-supported-systems fuse-2))
+ `(("fuse" ,fuse-2))
'())
("freetype" ,freetype)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 192b7faba9..a365cca849 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -605,7 +605,7 @@ software.")
(display "au BufNewFile,BufRead Tupfile,*.tup setf tup")))
#t))))))
(inputs
- (list fuse-3 pcre
+ (list fuse pcre
`(,pcre "bin") ; pcre-config
sqlite))
(native-inputs
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 0f1e70f4dc..07e718feaf 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -333,7 +333,7 @@ OpenBSD tool of the same name.")
("googletest-source" ,(package-source googletest))
("perl" ,perl)))
(inputs
- (list attr fuse openssl-1.1 tinyxml2))
+ (list attr fuse-2 openssl-1.1 tinyxml2))
(arguments
`(#:configure-flags (list "-DUSE_INTERNAL_TINYXML=OFF")
#:phases
@@ -1532,7 +1532,7 @@ non-encrypted files.")
(native-inputs
(list pkg-config python-wrapper))
(inputs
- (list boost curl fuse range-v3 spdlog))
+ (list boost curl fuse-2 range-v3 spdlog))
(home-page "https://www.cryfs.org/")
(synopsis "Encrypted FUSE filesystem for the cloud")
(description "CryFS encrypts your files, so you can safely store them anywhere.
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index a76e6c74c1..8d9ed917aa 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -198,7 +198,7 @@ large and/or frequently changing (network) environment.")
;; ("which" ,which)
(list pkg-config))
(inputs
- (list fuse))
+ (list fuse-2))
(home-page "https://bindfs.org")
(synopsis "Bind mount a directory and alter permission bits")
(description
@@ -275,7 +275,7 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
(arguments
'(#:configure-flags '("--enable-library" "--enable-fuse")))
(native-inputs (list pkg-config))
- (inputs (list xz fuse))
+ (inputs (list xz fuse-2))
(synopsis "Virtual file system that allows browsing of compressed files")
(description
"AVFS is a FUSE-based filesystem that allows browsing of compressed
@@ -565,7 +565,7 @@ AES-GCM implementation.")
(native-inputs
(list pkg-config))
(inputs
- (list fuse glib libgphoto2))
+ (list fuse-2 glib libgphoto2))
(synopsis "Virtual file system for libgphoto2 using FUSE")
(description "GPhotoFS is a FUSE file system module to mount your camera as
a file system on Linux. This allow using your camera with any tool able to read
@@ -756,7 +756,7 @@ Extensible File Allocation Table} file systems. Included are
(native-inputs
(list asciidoc docbook-xml libxml2 libxslt pkg-config))
(inputs
- (list fuse gnutls))
+ (list fuse-2 gnutls))
(arguments
(list #:phases
#~(modify-phases %standard-phases
@@ -921,7 +921,7 @@ files mistakenly overwritten or destroyed just a few seconds ago.")
(native-inputs
(list pkg-config))
(inputs
- (list fuse attr))
+ (list fuse-2 attr))
(arguments
`(#:phases (modify-phases %standard-phases
(delete 'configure)) ; no configure script
@@ -983,7 +983,7 @@ non-determinism in the build process.")
("cmocka" ,cmocka)))
(inputs
`(("acl" ,acl)
- ("fuse" ,fuse)
+ ("fuse" ,fuse-2)
("openssl" ,openssl)
("liburcu" ,liburcu)
("libuuid" ,util-linux "lib")
@@ -1030,7 +1030,7 @@ All of this is accomplished without a centralized metadata server.")
(("4426192") "12814800"))
#t)))))
(inputs
- (list curl glib fuse))
+ (list curl glib fuse-2))
(native-inputs
(list pkg-config))
(home-page "https://curlftpfs.sourceforge.net/")
@@ -1178,7 +1178,7 @@ network. LIBNFS offers three different APIs, for different use :
(arguments
`(#:tests? #f ; No test suite
#:configure-flags
- '("-DUSE_FUSE3=OFF") ; FUSE 3 is not packaged yet.
+ '("-DUSE_FUSE3=OFF")
#:phases
(modify-phases %standard-phases
;; No 'install' target in CMakeLists.txt
@@ -1196,7 +1196,7 @@ network. LIBNFS offers three different APIs, for different use :
(install-file "../source/README.md" doc)
#t))))))
(inputs
- (list bzip2 fuse zlib))
+ (list bzip2 fuse-2 zlib))
(synopsis "Read-only FUSE driver for the APFS file system")
(description "APFS-FUSE is a read-only FUSE driver for the @dfn{Apple File
System} (APFS). It is currently in an experimental state — it may not be able
@@ -1614,7 +1614,7 @@ On Guix System, you will need to invoke the included shell scripts as
(("/sbin") "$(EXEC_PREFIX)/sbin")
(("chown") "true") ; disallowed in the build environment
(("strip") "true")) ; breaks cross-compilation
- ;; These were copied from the fuse package.
+ ;; These were copied from the fuse-2 package.
(substitute* '("libfuse/lib/mount_util.c"
"libfuse/util/mount_util.c")
(("/bin/(u?)mount" _ maybe-u)
@@ -1811,7 +1811,7 @@ local file system using FUSE.")
(native-inputs
(list pkg-config))
(inputs
- (list fuse pcre))
+ (list fuse-2 pcre))
(home-page "https://github.com/sloonz/rewritefs")
(synopsis "FUSE file system that changes particular file names")
(description
@@ -1839,7 +1839,7 @@ the XDG directory specification from @file{~/.@var{name}} to
(base32 "03aw8pw8694jyrzpnbry05rk9718sqw66kiyq878bbb679gl7224"))))
(build-system gnu-build-system)
(native-inputs (list autoconf automake libtool pkg-config))
- (inputs (list attr fuse xz zlib `(,zstd "lib")))
+ (inputs (list attr fuse-2 xz zlib `(,zstd "lib")))
(home-page "https://github.com/vasi/squashfuse")
(synopsis "Fuse filesystem to mount squashfs archives")
(description
@@ -1935,7 +1935,7 @@ and rewritable media that wears out (DVD/CD-RW).")
(native-inputs
(list automake autoconf libtool pkg-config))
(inputs
- (list fuse-3))
+ (list fuse))
(home-page "https://github.com/containers/fuse-overlayfs")
(synopsis "FUSE implementation of overlayfs")
(description "This package provides an implementation of overlay+shiftfs
@@ -2056,7 +2056,7 @@ spend on disk between being written and being deduplicated.")
boost
double-conversion
fmt
- fuse-3
+ fuse
gflags
jemalloc
libarchive
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3bfc8b33ae..60e1e18ade 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2798,7 +2798,7 @@ compatible with the well-known scripts of the same name.")
("dbus" ,dbus)
("geoclue" ,geoclue)
("pipewire" ,pipewire)
- ("fuse" ,fuse-3)))
+ ("fuse" ,fuse)))
(arguments
`(#:configure-flags
(list "--with-systemd=no")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 11085ecc80..b09d9b4afd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7008,7 +7008,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
docbook-xsl
dbus
elogind
- fuse-3
+ fuse
gcr
glib
gnome-online-accounts
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 5e8e69487e..8ad24931b2 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -507,7 +507,7 @@ the functionality of the KDE resource and network access abstractions.")
(invoke "dbus-launch" "ctest" "-E"
"(fileopstest-cache|fileopstest-filejob)")))))))
(native-inputs (list dbus extra-cmake-modules pkg-config))
- (inputs (list fuse-3 kio kcoreaddons qtbase-5))
+ (inputs (list fuse kio kcoreaddons qtbase-5))
(home-page "https://community.kde.org/Frameworks")
(synopsis "FUSE Interface for KIO")
(description "This package provides FUSE Interface for KIO.")
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 13090d30ab..22803fa021 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -523,7 +523,7 @@ music and video to the device.")
(base32
"11wdv44qwia77sh38n36809ysaib52rwd4fvqwb5ybsbz4p70l1m"))))
(inputs
- (list fuse libimobiledevice))
+ (list fuse-2 libimobiledevice))
(native-inputs
(list pkg-config))
(build-system gnu-build-system)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bfe6f53386..ea0a923f67 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2309,7 +2309,7 @@ by Robert Shea and Robert Anton Wilson.")
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ;no test suite
- (inputs (list fuse mbedtls-apache))
+ (inputs (list fuse-2 mbedtls-apache))
(synopsis "FUSE driver to read/write Windows BitLocker drives")
(description
"This package provides means to to read BitLocker encrypted
@@ -3692,7 +3692,7 @@ are blocking others and adjust their priority (using @command{ionice}) or stop
or kill them altogether.")
(license license:gpl2+)))
-(define-public fuse
+(define-public fuse-2
(package
(name "fuse")
(version "2.9.9")
@@ -3762,9 +3762,9 @@ user-space processes.")
(license (list license:lgpl2.1 ;library
license:gpl2+)))) ;command-line utilities
-(define-public fuse-3
+(define-public fuse
(package
- (inherit fuse)
+ (inherit fuse-2)
(name "fuse")
(version "3.10.5")
(source (origin
@@ -3838,7 +3838,7 @@ user-space processes.")
(build-system cmake-build-system)
(native-inputs
(list python))
- (inputs (list fuse))
+ (inputs (list fuse-2))
(arguments
;; The tests were never actually run ("collected 0 items"), but in recent
;; versions of pytest that causes an error.
@@ -3852,10 +3852,10 @@ space, using the FUSE library. Mounting a union file system allows you to
UnionFS-FUSE additionally supports copy-on-write.")
(license license:bsd-3)))
-(define fuse-static
- (package (inherit fuse)
+(define fuse-2-static
+ (package (inherit fuse-2)
(name "fuse-static")
- (source (origin (inherit (package-source fuse))
+ (source (origin (inherit (package-source fuse-2))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3903,7 +3903,7 @@ UnionFS-FUSE additionally supports copy-on-write.")
;; we don't need it, remove it.
(delete-file (string-append out "/bin/unionfsctl"))
#t))))))
- (inputs `(("fuse" ,fuse-static)))))
+ (inputs `(("fuse" ,fuse-2-static)))))
(define-public sshfs
(package
@@ -3922,7 +3922,7 @@ UnionFS-FUSE additionally supports copy-on-write.")
;; XXX: tests are skipped: FUSE kernel module does not seem to be loaded
'(#:tests? #f))
(inputs
- (list fuse-3 glib))
+ (list fuse glib))
(native-inputs
(list pkg-config
;; man page
@@ -3953,7 +3953,7 @@ file system is as easy as logging into the server with an SSH client.")
(sha256
(base32 "1cy5b6qril9c3ry6fv7ir87s8iyy5vxxmbyx90dm86fbra0vjaf5"))))
(build-system gnu-build-system)
- (inputs (list fuse libarchive))
+ (inputs (list fuse-2 libarchive))
(native-inputs (list pkg-config))
(home-page "https://www.cybernoia.de/software/archivemount.html")
(synopsis "Tool for mounting archive files with FUSE")
@@ -5913,7 +5913,7 @@ is flexible, efficient and uses a modular implementation.")
(native-inputs
(list pkg-config))
(inputs
- (list fuse))
+ (list fuse-2))
(home-page "https://github.com/relan/exfat")
(synopsis "Mount exFAT file systems")
(description
@@ -5936,7 +5936,7 @@ write access to exFAT devices.")
(native-inputs
(list pkg-config))
(inputs
- (list fuse glib zlib))
+ (list fuse-2 glib zlib))
(home-page "https://sourceforge.net/projects/fuseiso/")
(synopsis "Mount ISO file system images")
(description
@@ -6611,7 +6611,7 @@ invocations of itself.")
"@sbindir@"))))))
(build-system gnu-build-system)
(inputs (list util-linux ; libuuid
- fuse))
+ fuse-2))
(native-inputs (list pkg-config))
(arguments
'(#:configure-flags (list "--disable-static"
@@ -8472,7 +8472,7 @@ NexGen, Rise, and SiS CPUs.")
"1pm68agkhrwgrplrfrnbwdcvx5lrivdmqw8pb5gdmm3xppnryji1"))))
(build-system gnu-build-system)
(inputs
- (list file fuse libmtp))
+ (list file fuse-2 libmtp))
(native-inputs
(list pkg-config))
(home-page "https://github.com/JasonFerrara/jmtpfs")
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b833ce29e7..dacd4433d2 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1863,7 +1863,7 @@ for packaging and deployment of cross-compiled Windows applications.")
docbook-xml
docbook-xsl
e2fsprogs
- fuse
+ fuse-2
glib
gpgme
libarchive
@@ -1964,7 +1964,7 @@ cp -r /tmp/locale/*/en_US.*")))
bubblewrap
curl
dconf
- fuse
+ fuse-2
gdk-pixbuf
gpgme
json-glib
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db3e69fb45..a59879cdf6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13306,7 +13306,7 @@ third-party code.")
"1jaf790rsxvz3hs9fbr3hrnmg0xzl6a2bqfa10bbbsjsdbcpk762"))))
(build-system python-build-system)
(inputs
- (list fuse attr))
+ (list fuse-2 attr))
(native-inputs
(list pkg-config python-pytest))
(synopsis "Python bindings for FUSE")
@@ -24387,10 +24387,9 @@ commit, but it also includes some other useful statistics.")
(let ((fuse (assoc-ref inputs "fuse")))
(substitute* "fuse.py"
(("find_library\\('fuse'\\)")
- (string-append "'" fuse "/lib/libfuse.so'")))
- #t))))))
+ (string-append "'" fuse "/lib/libfuse.so'")))))))))
(propagated-inputs
- (list fuse))
+ (list fuse-2))
(home-page "https://github.com/fusepy/fusepy")
(synopsis "Simple ctypes bindings for FUSE")
(description "Python module that provides a simple interface to FUSE and
@@ -24417,10 +24416,9 @@ MacFUSE. The binding is created using the standard @code{ctypes} library.")
(let ((fuse (assoc-ref inputs "fuse")))
(substitute* "fusepyng.py"
(("os.environ.get\\('FUSE_LIBRARY_PATH'\\)")
- (string-append "\"" fuse "/lib/libfuse.so\""))))
- #t)))))
+ (string-append "\"" fuse "/lib/libfuse.so\"")))))))))
(inputs
- (list fuse))
+ (list fuse-2))
(propagated-inputs
(list python-paramiko))
(home-page "https://github.com/rianhunter/fusepyng")
@@ -31962,10 +31960,10 @@ Psycopg 2 is both Unicode and Python 3 friendly.")
(base32 "0cvybynv9igssfa4l13q09gb6m7afmwk34wsbq8jk14sqpd4dl92"))))
(build-system python-build-system)
(native-inputs (list pkg-config))
- (inputs (list fuse-3))
+ (inputs (list fuse))
(propagated-inputs (list python-pytest-trio))
(home-page "https://github.com/libfuse/pyfuse3")
- (synopsis "Python bindings FUSE 3")
+ (synopsis "Python bindings to FUSE 3")
(description "This package provides Python 3 bindings for libfuse 3 with
async I/O support.")
(license license:gpl2+)))
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index f9b76b1d38..0dadd0914a 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -222,7 +222,7 @@
expat
fcgi
fmt-8
- fuse
+ fuse-2
icu4c
jemalloc
keyutils
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 28b5989d6a..8235332cb0 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -546,7 +546,7 @@ written in @command{scsh}. It makes use of @command{unison} and
acl
libselinux
eudev
- fuse
+ fuse-2
openssl
zlib))
(synopsis "File synchronization and backup system")
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index db7df83524..9372ad4e45 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1325,7 +1325,7 @@ manage system or application containers.")
(native-inputs
(list autoconf automake libtool pkg-config))
(inputs
- (list fuse))
+ (list fuse-2))
(build-system gnu-build-system)
(synopsis "FUSE-based file system for LXC")
(description "LXCFS is a small FUSE file system written with the intention
@@ -1499,7 +1499,7 @@ pretty simple, REST API.")
(inputs
(list acl
attr
- fuse
+ fuse-2
libxml2
eudev
libpciaccess
diff --git a/gnu/system.scm b/gnu/system.scm
index 23addf41e9..5598643910 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -1244,7 +1244,7 @@ deprecated; use 'setuid-program' instead~%"))
(file-append sudo "/bin/sudo")
(file-append sudo "/bin/sudoedit")
(file-append fuse "/bin/fusermount")
- (file-append fuse-3 "/bin/fusermount3")
+ (file-append fuse "/bin/fusermount3")
;; To allow mounts with the "user" option, "mount" and "umount" must
;; be setuid-root.