aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-07-20 08:57:27 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-25 12:38:16 +0800
commit7794cf9a80c290850f79c83ee9e6cda4d4f52b87 (patch)
treec9bc31f658937a4ce98e956c4503525a63ef4f8f /gnu
parent01506708c8342a33d74ea7d5d50a13859b7dce12 (diff)
downloadguix-7794cf9a80c290850f79c83ee9e6cda4d4f52b87.tar
guix-7794cf9a80c290850f79c83ee9e6cda4d4f52b87.tar.gz
gnu: mtxclient: Switch to new package style.
* gnu/packages/matrix.scm (mtxclient)[arguments]: Use g-exps. Change-Id: I044faf4e25b9e5d282e9364070a7e24bb6f89b5e Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4f065d4316..076861d963 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2431,19 +2431,18 @@ QMatrixClient project.")
(file-name (git-file-name name version))
(sha256
(base32 "10iidyxjk3w6cljw2r62i5azx84nw3p8hw97d8vy7r5gh1nrrrcn"))))
- (arguments
- `(#:configure-flags
- (list
- ;; Disable example binaries (not installed)
- "-DBUILD_LIB_EXAMPLES=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'disable-network-tests
- (lambda _
- (substitute* "CMakeLists.txt"
- (("add_test\\((BasicConnectivity|ClientAPI|Devices|MediaAPI|Encryption|Pushrules)")
- "# add_test")))))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-DBUILD_LIB_EXAMPLES=OFF") ; disable example binaries (not installed)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'disable-network-tests
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("add_test\\((BasicConnectivity|ClientAPI|Devices|MediaAPI|Encryption|Pushrules)")
+ "# add_test")))))))
(inputs
(list boost
coeurl