aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-12-15 12:26:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-12-15 16:13:08 +0100
commit7696d8869ebf0f7635e153f1343c09fff14cd5cb (patch)
tree7b396dcaeecf6c42bf1e237338ee732a9d5ec112 /gnu
parent7714e8fd32a7752159f541a65d1ad37238bc8a9d (diff)
downloadguix-7696d8869ebf0f7635e153f1343c09fff14cd5cb.tar
guix-7696d8869ebf0f7635e153f1343c09fff14cd5cb.tar.gz
gnu: Add r-ggstats.
* gnu/packages/cran.scm (r-ggstats): New variable. Change-Id: I0fb9465e059839443913b6935779e9656b1cc9ab
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6165d329d9..0a54c25bf8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -967,6 +967,40 @@ samples) are easily visualized.")
"Ggfittext is a ggplot2 extension for fitting text into boxes.")
(license license:gpl2)))
+(define-public r-ggstats
+ (package
+ (name "r-ggstats")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggstats" version))
+ (sha256
+ (base32 "1jcydapwarl1cxinm80rjmmli8vmlid8alnh6w484bh7nwzmcsic"))))
+ (properties `((upstream-name . "ggstats")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-broom-helpers
+ r-cli
+ r-dplyr
+ r-forcats
+ r-ggplot2
+ r-lifecycle
+ r-magrittr
+ r-patchwork
+ r-purrr
+ r-rlang
+ r-scales
+ r-stringr
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://larmarange.github.io/ggstats/")
+ (synopsis "Extension to ggplot2 for plotting stats")
+ (description
+ "This package provides new statistics, new geometries and new positions
+for ggplot2 and a suite of functions to facilitate the creation of statistical
+plots.")
+ (license license:gpl3+)))
+
(define-public r-ggstatsplot
(package
(name "r-ggstatsplot")