aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-24 18:26:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-24 18:36:45 +0200
commit7414698e61c18effe7a10be45127b8557e0be758 (patch)
tree3aa08be31272d30d0b68c7e47bc854342befd0c0 /gnu
parent93ab7e8d527e0a648f78421d631350fcdbbaa93e (diff)
downloadguix-7414698e61c18effe7a10be45127b8557e0be758.tar
guix-7414698e61c18effe7a10be45127b8557e0be758.tar.gz
gnu: java-jsoup: Don't use unstable tarball.
* gnu/packages/web.scm (java-jsoup)[source]: Download using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 851c66b33e..2a6fc98e85 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6542,12 +6542,14 @@ container.")))
(name "java-jsoup")
(version "1.10.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jhy/jsoup/archive/jsoup-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jhy/jsoup")
+ (commit (string-append "jsoup-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xbzw7rjv7s4nz1xk9b2cnin6zkpaldmc3svk71waa7hhjgp0a20"))))
+ "1hdpdx0x140r5x3yc251v7dj1h4j5a7nh9k885aw9q5vvz49lkf4"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "jsoup.jar"