aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-18 13:44:43 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-20 19:50:19 -0400
commit7357fcf286a9b11baad9798a106f21f8038db4ba (patch)
treed854619731e9a9a41f3f3134e1507cb50c51f958 /gnu
parent92321b76a6dccbfd00734d444386561102c325d9 (diff)
downloadguix-7357fcf286a9b11baad9798a106f21f8038db4ba.tar
guix-7357fcf286a9b11baad9798a106f21f8038db4ba.tar.gz
gnu: Add nml.
* gnu/packages/game-development.scm (nml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 34a08f6d84..bf19f9e73f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -188,6 +188,30 @@ and network communications. A very thin client library can be embedded to
provide connectivity for client applications written in any language.")
(license license:gpl3+)))
+(define-public nml
+ (package
+ (name "nml")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://bundles.openttdcoop.org/nml/releases/"
+ version "/nml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wk9ls5qyjwkra54rkj1gg94xbwzi7b84a5fh1ma1q7pbimi8rmg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pillow" ,python-pillow)
+ ("python-ply" ,python-ply)))
+ (home-page "http://dev.openttdcoop.org/projects/nml")
+ (synopsis "NML compiler")
+ (description
+ "@dfn{NML} (NewGRF Meta Language) is a a python-based compiler, capable of
+compiling NML files (along with their associated language, sound and graphic
+files) into @file{.grf} and/or @file{.nfo} files.")
+ (license license:gpl2+)))
+
(define-public python-sge-pygame
(package
(name "python-sge-pygame")