aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 13:14:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 13:17:11 +0200
commit72e782b2b587d05e89b2ca9b27b30c93653760f5 (patch)
tree8293edb2cc6c5e5e15b97e44a0de1f512d42b8e4 /gnu
parent3004f1c69b258837b0e49a567787c97479ce6e71 (diff)
downloadguix-72e782b2b587d05e89b2ca9b27b30c93653760f5.tar
guix-72e782b2b587d05e89b2ca9b27b30c93653760f5.tar.gz
gnu: strace: Disable parallel tests.
Tests fail in undeterministic fashion when run in parallel on phat rigs. Fixes <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>. Reported by Clément Lassieur <clement@lassieur.org>. * gnu/packages/linux.scm (strace)[arguments]: Disable #:parallel-tests?.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6d80a3ad22..c8d6806646 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -957,7 +957,9 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(lambda _
(substitute* "strace.c"
(("/bin/sh") (which "sh")))
- #t)))))
+ #t)))
+ ;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.
+ #:parallel-tests? #f)) ; undeterministic failures
(native-inputs `(("perl" ,perl)))
(synopsis "System call tracer for Linux")
(description