aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-06-25 15:14:16 +0200
committerLudovic Courtès <ludo@gnu.org>2024-07-26 19:21:34 +0200
commit72e586fcae78e467d01e2add09c1db26be6bfa93 (patch)
tree98877e02b732fd7dede6e662e14a4f5ab403bb17 /gnu
parent9db34c41acae675041e2d0a72e72688b7b58d114 (diff)
downloadguix-72e586fcae78e467d01e2add09c1db26be6bfa93.tar
guix-72e586fcae78e467d01e2add09c1db26be6bfa93.tar.gz
gnu: gtk: Fix build on aarch64.
* gnu/packages/gtk.scm (gtk)[arguments]<#:test-options>: Rename failing test suite to match upstream change on aarch64-linux. Change-Id: Ibdf03a94e71f72283a093cba6d5a328004defa5c Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm36
1 files changed, 23 insertions, 13 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fb10351849..e5da382a12 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1171,19 +1171,29 @@ application suites.")
'("-Dgtk_doc=false")
'("-Dgtk_doc=true"))
"-Dman-pages=true")
- #:test-options '(list "--setup=x11" ;defaults to wayland
- ;; Use the same test options as upstream uses for
- ;; their CI.
- "--suite=gtk"
- "--no-suite=failing"
- "--no-suite=flaky"
- "--no-suite=headless" ; requires mutter…
- "--no-suite=gsk-compare-broadway"
- ;; These seem to fail on aarch64, and Debian has
- ;; also disabled these, see:
- ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
- "--no-suite=wayland_failing"
- "--no-suite=wayland_gles_failing")
+ #:test-options #~(list "--setup=x11" ;defaults to wayland
+ ;; Use the same test options as upstream uses for
+ ;; their CI.
+ "--suite=gtk"
+ "--no-suite=failing"
+ "--no-suite=flaky"
+ "--no-suite=headless" ; requires mutter…
+ "--no-suite=gsk-compare-broadway"
+ ;; These seem to fail on aarch64, and Debian has
+ ;; also disabled these, see:
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
+ "--no-suite=wayland_failing"
+
+ ;; The correct name of the test that fails on
+ ;; AArch64 is 'wayland_gles2_failing':
+ ;; <https://gitlab.gnome.org/GNOME/gtk/-/commit/b916c4dac1075572>.
+ ;; The second arm of the 'if' is kept to avoid a
+ ;; rebuild on other architectures. TODO: Remove
+ ;; on the next rebuild cycle.
+ #$(if (and (not (%current-target-system))
+ (string=? (%current-system) "aarch64-linux"))
+ "--no-suite=wayland_gles2_failing"
+ "--no-suite=wayland_gles_failing"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file