aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-25 12:01:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-23 10:06:27 +0100
commit71d7702faed660567d165488ef9d3bde287786d5 (patch)
tree390d26e8270225b2ec5fc441fd85353722f7aceb /gnu
parent959a397d220ad49b5193feb84b036220313fb9c7 (diff)
downloadguix-71d7702faed660567d165488ef9d3bde287786d5.tar
guix-71d7702faed660567d165488ef9d3bde287786d5.tar.gz
gnu: texlive-latex-base: Use character translation file.
* gnu/packages/tex.scm (texlive-latex-base)[arguments]: Patch fmtutil.cnf to ensure that the character translation file cp227.tcx is used during format file generation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4e7196e4f7..d01387d26d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2471,7 +2471,10 @@ formats.")
(make-file-writable "web2c/fmtutil.cnf")
(substitute* "web2c/fmtutil.cnf"
(((string-append "^(" (string-join disabled-formats "|") ")") m)
- (string-append "#! " m))))
+ (string-append "#! " m))
+ (("translate-file=cp227")
+ (format #f "translate-file=~a/share/texmf-dist/web2c/cp227"
+ (assoc-ref inputs "texlive-kpathsea")))))
(invoke "fmtutil-sys" "--all"
"--fmtdir=web2c"
(string-append "--cnffile=web2c/fmtutil.cnf"))