aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:23:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:38 +0200
commit71028d8eadf343c2848a5cded47597a20447f4e9 (patch)
treee8f583f0c841eff481a30948186ac823c1103151 /gnu
parent3999388a1cb14adae2cb5f27e7be5c83f0f4961d (diff)
downloadguix-71028d8eadf343c2848a5cded47597a20447f4e9.tar
guix-71028d8eadf343c2848a5cded47597a20447f4e9.tar.gz
gnu: Add texlive-pst-lens.
* gnu/packages/tex.scm (texlive-pst-lens): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 444f921698..a83a31de53 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33359,6 +33359,28 @@ of illustrations together with their source code, making it an easy read.")
layouts of material, typically to be overlaid on an included graphic.")
(license license:lppl)))
+(define-public texlive-pst-lens
+ (package
+ (name "texlive-pst-lens")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-lens/"
+ "source/generic/pst-lens/"
+ "tex/generic/pst-lens/"
+ "tex/latex/pst-lens/")
+ (base32
+ "0h2930i4izgfjk96445yiwsk6x8cg5cl4zlqrg5rsv7nr2k8njy3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-lens")
+ (synopsis "Lenses with PSTricks")
+ (description
+ "This PSTricks package provides a really rather simple command
+@code{\\PstLens} that will draw a lens. Command parameters provide
+a remarkable range of effects.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")