aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:34 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:37 +0100
commit7068bb376fb84ff62c0ed488f1daaf30c2322a9c (patch)
treed5b42004d6f086c4b1eb4adc3bed2329c3476efa /gnu
parent66685821dccee8bfa116a330d12fd483807383ad (diff)
downloadguix-7068bb376fb84ff62c0ed488f1daaf30c2322a9c.tar
guix-7068bb376fb84ff62c0ed488f1daaf30c2322a9c.tar.gz
gnu: Add python-perfplot.
* gnu/packages/python-xyz.scm (python-perfplot): New variable. Change-Id: I04266dfd7081bd3f917a48b2667137b829680498 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6c5f4603e..4af189b1aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8381,6 +8381,30 @@ clean plots with a minimalistic style.")
complex-valued functions.")
(license license:gpl3+)))
+(define-public python-perfplot
+ (package
+ (name "python-perfplot")
+ (version "0.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "perfplot" version))
+ (sha256
+ (base32
+ "0hbyv17f9ra6l6albcrqx4rylmfv2m6z4qsnhb4bar256dralvfp"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-matplotlib
+ python-matplotx
+ python-numpy
+ python-rich))
+ (native-inputs (list python-flit-core
+ python-pytest))
+ (home-page "https://github.com/nschloe/perfplot")
+ (synopsis "Performance plots for Python code snippets")
+ (description "@code{perfplot} extends Python's timeit by testing
+snippets with input parameters (e.g., the size of an array) and plotting
+the results.")
+ (license license:gpl3+)))
+
(define-public python-pysnptools
(package
(name "python-pysnptools")