aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-09 16:40:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:49 -0400
commit6c789555a5d8d59f80f04e4303cf401edc275232 (patch)
tree2e6f18259cb7769b4bfbc637287bd129e5301365 /gnu
parent255935a2fff1a4e26fdd089d74dd80f91a284a6d (diff)
downloadguix-6c789555a5d8d59f80f04e4303cf401edc275232.tar
guix-6c789555a5d8d59f80f04e4303cf401edc275232.tar.gz
gnu: network-manager-openvpn: Update to 1.10.0.
* gnu/packages/gnome.scm (network-manager-openvpn): Update to 1.10.0. [configure-flags]: Add "--with-gtk4=yes". [phases]: Delete trailing #t. [native-inputs]: add glib:bin. [inputs]: Add gtk and pango-next; sort inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm53
1 files changed, 30 insertions, 23 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b83d93b3f7..615499d618 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8252,7 +8252,7 @@ services.")
(define-public network-manager-openvpn
(package
(name "network-manager-openvpn")
- (version "1.8.12")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8261,35 +8261,42 @@ services.")
"/NetworkManager-openvpn-" version ".tar.xz"))
(sha256
(base32
- "062kh4zj7jfbwy4zzcwpq2m457bzbpm3l18s0ysnw3mgia3siz8f"))))
+ "00fiyjbp42pdv5h2vdkzxd2rw32ikcinjgxrzdxak61kgw8d8iap"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--enable-absolute-paths" "--localstatedir=/var")
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'patch-path
- (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
- (let* ((ovpn (search-input-file inputs "/sbin/openvpn"))
- (modprobe (search-input-file inputs "/bin/modprobe"))
- (pretty-ovpn (string-append "\"" ovpn "\"")))
- (for-each
- (lambda (file)
- (substitute* file
- (("\"/usr/local/sbin/openvpn\"") pretty-ovpn)
- (("\"/usr/sbin/openvpn\"") pretty-ovpn)
- (("\"/sbin/openvpn\"") pretty-ovpn)
- (("/sbin/modprobe") modprobe)))
- '("src/nm-openvpn-service.c" "properties/nm-openvpn-editor.c")))
- #t)))))
+ (list
+ #:configure-flags #~(list "--enable-absolute-paths"
+ "--localstatedir=/var"
+ "--with-gtk4=yes")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let* ((ovpn (search-input-file inputs "/sbin/openvpn"))
+ (modprobe (search-input-file inputs "/bin/modprobe"))
+ (pretty-ovpn (string-append "\"" ovpn "\"")))
+ (for-each
+ (lambda (file)
+ (substitute* file
+ (("\"/usr/local/sbin/openvpn\"") pretty-ovpn)
+ (("\"/usr/sbin/openvpn\"") pretty-ovpn)
+ (("\"/sbin/openvpn\"") pretty-ovpn)
+ (("/sbin/modprobe") modprobe)))
+ '("src/nm-openvpn-service.c"
+ "properties/nm-openvpn-editor.c"))))))))
(native-inputs
- (list pkg-config intltool))
+ (list intltool
+ `(,glib "bin")
+ pkg-config))
(inputs
(list gtk+
+ gtk
kmod
- openvpn
- network-manager
libnma
- libsecret))
+ libsecret
+ network-manager
+ openvpn
+ pango-next)) ;remove after it's the default
(home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
(synopsis "OpenVPN plug-in for NetworkManager")
(description