aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-05-13 20:52:12 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-24 10:59:58 +0100
commit6c72e72ae80ac3ab8b810c0df187df52c1ecbebe (patch)
treeb29e22981f8d8156ccc8ac60bc8cd697fe0549ae /gnu
parent68fe21b5b2ed34302e55797cead64830775a1a1f (diff)
downloadguix-6c72e72ae80ac3ab8b810c0df187df52c1ecbebe.tar
guix-6c72e72ae80ac3ab8b810c0df187df52c1ecbebe.tar.gz
gnu: Add primecount.
* gnu/packages/maths.scm (primecount): New variable. Change-Id: I03692a1be46cc4d0f3eabe95a3f76719a5c63d83 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8a00cc83c6..94187be6b7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3682,6 +3682,31 @@ termination analysis via the automatic synthesis of linear ranking
functions.")
(license license:gpl3+)))
+(define-public primecount
+ (package
+ (name "primecount")
+ (version "7.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kimwalisch/primecount")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v3zm6mw4fb6a33zi542x94w1nd54rvn7r8dav670jm9dn60jfsn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_STATIC_LIBS=OFF"
+ "-DBUILD_TESTS=ON")))
+ (home-page "https://github.com/kimwalisch/primecount")
+ (synopsis "Fast prime counting function implementations")
+ (description "@code{primecount} is a command-line program and C/C++
+library that counts the number of primes ≤ x (maximum 1031) using highly
+optimized implementations of the combinatorial prime counting algorithms.")
+ (license license:bsd-2)))
+
(define-public primesieve
(package
(name "primesieve")