aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:35:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:35:42 +0100
commit69b0178ba62cd4c2de2aa87d292cf4c7f465a3a0 (patch)
tree6bb6a8b32f2a93757590450d7a2f2b18fd808800 /gnu
parente799307decc7187352fb21c4d78b312c66e9aa78 (diff)
downloadguix-69b0178ba62cd4c2de2aa87d292cf4c7f465a3a0.tar
guix-69b0178ba62cd4c2de2aa87d292cf4c7f465a3a0.tar.gz
gnu: go-github-com-goccy-go-yaml: Enable all tests.
* gnu/packages/golang-xyz.scm (go-github-com-goccy-go-yaml) [arguments]: <#:phases>: Use customer 'check phase. Change-Id: Idb607eef3cb09cfa3694a25d0acf8bfa0be22bcc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 56b4ae9a65..fbe5921e25 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2042,7 +2042,13 @@ the library more lightweight.")
(add-after 'unpack 'remove-benchmarks
(lambda* (#:key import-path #:allow-other-keys)
(delete-file-recursively
- (string-append "src/" import-path "/benchmarks")))))))
+ (string-append "src/" import-path "/benchmarks"))))
+ ;; XXX: Replace when go-build-system supports nested path.
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(native-inputs
(list go-github-com-go-playground-validator-v10
go-github-com-google-go-cmp-cmp))