aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-07-05 14:45:13 +0200
committerChristopher Baines <mail@cbaines.net>2024-07-15 22:34:24 +0100
commit67b212ff6038ec8827e224603c85db55481fb3e6 (patch)
tree4516922d38a7bb7fc5204a73433501ba2fa7781c /gnu
parente661121e39c664a1b985fafc3e6bdb830ada58fd (diff)
downloadguix-67b212ff6038ec8827e224603c85db55481fb3e6.tar
guix-67b212ff6038ec8827e224603c85db55481fb3e6.tar.gz
gnu: rust: Guard against unsupported rust targets.
As cross-libc may return #f in this case, and the config.toml file construction will also fail if the platform rust-target is #f.. * gnu/packages/rust.scm (make-rust-sysroot/implementation): Guard against unsupported rust targets. Change-Id: Ia0d5c889c6f5cd3478ad985c79feb9ba1c472c29
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a385344473..8119f4560a 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -73,7 +73,9 @@
#:use-module (ice-9 match)
#:use-module (ice-9 optargs)
#:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26))
+ #:use-module (srfi srfi-26)
+ #:use-module (srfi srfi-34)
+ #:use-module (srfi srfi-35))
;; This is the hash for the empty file, and the reason it's relevant is not
;; the most obvious.
@@ -1309,6 +1311,13 @@ exec -a \"$0\" \"~a\" \"$@\""
(define make-rust-sysroot/implementation
(mlambda (target base-rust)
+ (unless (platform-rust-target (lookup-platform-by-target target))
+ (raise
+ (condition
+ (&package-unsupported-target-error
+ (package base-rust)
+ (target target)))))
+
(package
(inherit base-rust)
(name (string-append "rust-sysroot-for-" target))