aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2018-12-27 10:54:34 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-13 23:30:15 +0100
commit64d25f0be214795050b058047133d11f1d5dcbf5 (patch)
tree35a701e56c34df18b28f2eea3374755f1a8ae40c /gnu
parentcc353cc067904f9d9c57b053a84ce62c6981436b (diff)
downloadguix-64d25f0be214795050b058047133d11f1d5dcbf5.tar
guix-64d25f0be214795050b058047133d11f1d5dcbf5.tar.gz
gnu: Add ocaml-merlin.
* gnu/packages/ocaml.scm (ocaml-merlin): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 822075d195..675b031b6e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4749,6 +4749,37 @@ yojson package. The program @code{atdgen} can be used to derive OCaml-JSON
serializers and deserializers from type definitions.")
(license license:bsd-3)))
+(define-public ocaml-merlin
+ (package
+ (name "ocaml-merlin")
+ (version "3.2.2")
+ (home-page "https://ocaml.github.io/merlin/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/merlin.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15ssgmwdxylbwhld9p1cq8x6kadxyhll5bfyf11dddj6cldna3hb"))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-biniou" ,ocaml-biniou)
+ ("ocaml-yojson" ,ocaml-yojson)
+ ("ocaml-easy-format" ,ocaml-easy-format)))
+ (native-inputs
+ `(("ocaml-findlib" ,ocaml-findlib)))
+ (arguments
+ '(#:tests? #f)) ;; Errors in tests in version 3.2.2
+ (synopsis "Context sensitive completion for OCaml in Vim and Emacs")
+ (description "Merlin is an editor service that provides modern IDE
+features for OCaml. Emacs and Vim support is provided out-of-the-box.
+External contributors added support for Visual Studio Code, Sublime Text and
+Atom.")
+ (license license:expat)))
+
(define-public ocaml-gsl
(package
(name "ocaml-gsl")