aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-08 22:13:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 18:45:31 +0100
commit61124bc7b0b03dd9c1208446109e91fbc147bc03 (patch)
treeedffb1848f13a5f89b6bc0b1bf3bdf82698e2111 /gnu
parentca7141234d0268a55ee1e06d00cb7ed952451745 (diff)
downloadguix-61124bc7b0b03dd9c1208446109e91fbc147bc03.tar
guix-61124bc7b0b03dd9c1208446109e91fbc147bc03.tar.gz
gnu: Add r-shinycustomloader.
* gnu/packages/cran.scm (r-shinycustomloader): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7d069dcf49..d904e5d00e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17808,6 +17808,29 @@ intersecting sets using a novel matrix design, along with visualizations of
several common set, element and attribute related tasks.")
(license license:expat)))
+(define-public r-shinycustomloader
+ (package
+ (name "r-shinycustomloader")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "shinycustomloader" version))
+ (sha256
+ (base32
+ "1klx71vr26g0gjf6hbiia1qidqii5d467i1sdjvlrg1hxdcggqff"))))
+ (properties `((upstream-name . "shinycustomloader")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-glue
+ r-shiny))
+ (home-page "https://cran.r-project.org/package=shinycustomloader")
+ (synopsis "Custom loader for Shiny outputs")
+ (description
+ "This package provides a custom @code{CSS/HTML} or @code{GIF/image} file
+for the loading screen in R @code{Shiny}. It also can use the marquee to have
+a custom text loading screen.")
+ (license license:gpl3)))
+
;; This package includes a JavaScript file, which is not minified. When
;; upgrading please check that there are no new minified JavaScript files.
(define-public r-shinybs