aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-07 15:21:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 15:21:09 +0100
commit60a166c629f98d763c3bee66e3772e331ec4b351 (patch)
tree331104f5956b807ea4d41d1538d9300fd021a266 /gnu
parent67eebb19b70acfe997b40d8c7978f9dc0673a4af (diff)
downloadguix-60a166c629f98d763c3bee66e3772e331ec4b351.tar
guix-60a166c629f98d763c3bee66e3772e331ec4b351.tar.gz
gnu: r-feather: Move from serialization.scm to cran.scm.
* gnu/packages/serialization.scm (r-feather): Move from here... * gnu/packages/cran.scm (r-feather): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
-rw-r--r--gnu/packages/serialization.scm27
2 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 68c4431a68..20730c5daf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
+;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -775,6 +776,28 @@ named elements: the @code{status}, the @code{headers}, and the @code{body}.")
work well on small screens.")
(license license:gpl3)))
+(define-public r-feather
+ (package
+ (name "r-feather")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "feather" version))
+ (sha256
+ (base32
+ "1q6dbkfnkpnabq8lb6bm9ma44cfcghx2lm23pyk3vg7943wrn1pi"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-hms" ,r-hms)
+ ("r-rcpp" ,r-rcpp)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/wesm/feather")
+ (synopsis "R Bindings to the Feather API")
+ (description "Read and write feather files, a lightweight binary columnar
+data store designed for maximum speed.")
+ (license license:asl2.0)))
+
(define-public r-haven
(package
(name "r-haven")
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index f5e40bdf73..489c53f41d 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -34,20 +34,17 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
- #:use-module (guix build-system r)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
- #:use-module (gnu packages cran)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages lua)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages statistics))
+ #:use-module (gnu packages perl))
(define-public cereal
(package
@@ -477,28 +474,6 @@ C#, C, Go, Java, JavaScript, PHP, and Python. It was originally created for
game development and other performance-critical applications.")
(license license:asl2.0)))
-(define-public r-feather
- (package
- (name "r-feather")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "feather" version))
- (sha256
- (base32
- "1q6dbkfnkpnabq8lb6bm9ma44cfcghx2lm23pyk3vg7943wrn1pi"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-hms" ,r-hms)
- ("r-rcpp" ,r-rcpp)
- ("r-tibble" ,r-tibble)))
- (home-page "https://github.com/wesm/feather")
- (synopsis "R Bindings to the Feather API")
- (description "Read and write feather files, a lightweight binary columnar
-daa store designed for maximum speed.")
- (license license:asl2.0)))
-
(define-public python-feather-format
(package
(name "python-feather-format")