aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 18:10:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 18:10:13 +0100
commit5fb05d74ad183cb579146a12bb9b1d02b2516814 (patch)
tree5eb9898cc9c43e73c5dc3dca7364f548b7fe0921 /gnu
parentd275a15163a93b8155f86676b8966bece3882079 (diff)
downloadguix-5fb05d74ad183cb579146a12bb9b1d02b2516814.tar
guix-5fb05d74ad183cb579146a12bb9b1d02b2516814.tar.gz
gnu: go-github-com-kr-pretty: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-kr-pretty): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ifded1d309f10d25c982afaf20301bc151f1c8ba1
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 27 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 43b99f2c1b..8dad9f0757 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,14 +1,15 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017-2020 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2018, 2020 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019, 2021 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019-2021 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
@@ -3322,6 +3323,31 @@ very eas to use.")
(list
#:import-path "github.com/klauspost/cpuid/v2"))))
+(define-public go-github-com-kr-pretty
+ (package
+ (name "go-github-com-kr-pretty")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kr/pretty")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19d4ycy22il43s4pnr7jv1aahp87wa1p16zpis5jdiiyfgni2l8f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kr/pretty"))
+ (propagated-inputs
+ (list go-github-com-kr-text go-github-com-rogpeppe-go-internal))
+ (home-page "https://github.com/kr/pretty")
+ (synopsis "Pretty printer for Go values")
+ (description
+ "This package provides a pretty printer for Go values.")
+ (license license:expat)))
+
(define-public go-github-com-lestrrat-go-envload
(package
(name "go-github-com-lestrrat-go-envload")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ae62246697..753fd3f56c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5069,29 +5069,6 @@ have super fancy logs.")
format in Go.")
(license license:expat))))
-(define-public go-github-com-kr-pretty
- (package
- (name "go-github-com-kr-pretty")
- (version "0.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kr/pretty")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19d4ycy22il43s4pnr7jv1aahp87wa1p16zpis5jdiiyfgni2l8f"))))
- (build-system go-build-system)
- (propagated-inputs
- (list go-github-com-kr-text go-github-com-rogpeppe-go-internal))
- (arguments
- '(#:import-path "github.com/kr/pretty"))
- (synopsis "Pretty printer for Go values")
- (description "This package provides a pretty printer for Go values.")
- (home-page "https://github.com/kr/pretty")
- (license license:expat)))
-
(define-public go-github-com-kylelemons-godebug
(package
(name "go-github-com-kylelemons-godebug")