aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-22 08:56:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-22 08:56:50 +0100
commit5e5debf58c5cf3834dfff7f4f13eac7d242246ed (patch)
tree16663c72c23c62db52c37ef834dcd0e3d0e1ac12 /gnu
parentbbc8f4c29ed9efc1240c3d153fb234d7a79930fd (diff)
downloadguix-5e5debf58c5cf3834dfff7f4f13eac7d242246ed.tar
guix-5e5debf58c5cf3834dfff7f4f13eac7d242246ed.tar.gz
gnu: Add r-gwidgets2.
* gnu/packages/cran.scm (r-gwidgets2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 38e1a84282..2b1bea9ea0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -717,6 +717,27 @@ differential abundance analysis of zero-inflated high-dimensional
compositional data.")
(license license:gpl3)))
+(define-public r-gwidgets2
+ (package
+ (name "r-gwidgets2")
+ (version "1.0-9")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "gWidgets2" version))
+ (sha256
+ (base32
+ "1ifljpdazzmwf3mgkg9g76365n2cmw8dd3da161fpvw84xxyznfl"))))
+ (properties `((upstream-name . "gWidgets2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-digest))
+ (home-page "https://github.com/gWidgets3/gWidgets2")
+ (synopsis "Rewrite of gWidgets API for simplified GUI construction")
+ (description
+ "This package provides a re-implementation of the @code{gWidgets} API.
+The API is defined in this package. A second, toolkit-specific package is
+required to use it.")
+ (license license:gpl3+)))
+
(define-public r-ids
(package
(name "r-ids")