aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-10-25 09:38:25 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-26 10:10:12 +0800
commit5c5c9fa39d713a63c30bcee9602bd69ec94d699f (patch)
treec264b9a841c7fafe33cb6218fe4e7f11af358177 /gnu
parentde9a96dc80f4452cc7aba42b8d2f61f3ff483b4d (diff)
downloadguix-5c5c9fa39d713a63c30bcee9602bd69ec94d699f.tar
guix-5c5c9fa39d713a63c30bcee9602bd69ec94d699f.tar.gz
gnu: kdiskmark: Update to 3.1.4. [security fixes]
This fixes CVE-2022-40673. * gnu/packages/benchmark.scm (kdiskmark): Update to 3.1.4. [arguments]<#:configure-flags>: Adapt for polkit-qt. <#:phases>: Add phase 'inject-single-application-source. [inputs]: Add polkit-qt, single-application-qt5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/benchmark.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 9be03cff08..326bbc99b4 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages php)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-science)
@@ -559,7 +561,7 @@ and options. With careful benchmarking, different hardware can be compared.")
(define-public kdiskmark
(package
(name "kdiskmark")
- (version "2.3.0")
+ (version "3.1.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -568,13 +570,14 @@ and options. With careful benchmarking, different hardware can be compared.")
(file-name (git-file-name name version))
(sha256
(base32
- "1l4sw05yx70pcnaa64arjc414mgvyz05pn3gz9nc9hga8v2d3rzn"))))
+ "1x8vd6swmf0i7f6m6wl2154n6plx8jkmcqfq6zxbdy255f1da74c"))))
(build-system cmake-build-system)
(arguments
(list
#:configure-flags
;; Drop runtime dependency on KDE's KFAuth.
- #~(list "-DPERFORM_PAGECACHE_CLEARING_USING_KF5AUTH=no")
+ #~(list "-DPERFORM_PAGECACHE_CLEARING_USING_KF5AUTH=no"
+ (string-append "-DPOLKITQT-1_INSTALL_DIR=" #$output))
#:tests? #f ;no test suite
#:phases
#~(modify-phases %standard-phases
@@ -582,9 +585,15 @@ and options. With careful benchmarking, different hardware can be compared.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/benchmark.cpp"
(("\"fio\"")
- (format #f "~s" (search-input-file inputs "bin/fio")))))))))
+ (format #f "~s" (search-input-file inputs "bin/fio"))))))
+ (add-after 'unpack 'inject-single-application-source
+ (lambda _
+ (rmdir "src/singleapplication")
+ (symlink #$(package-source
+ (this-package-input "single-application-qt5"))
+ "src/singleapplication"))))))
(native-inputs (list extra-cmake-modules qttools-5))
- (inputs (list fio qtbase-5))
+ (inputs (list fio polkit-qt qtbase-5 single-application-qt5))
(home-page "https://github.com/JonMagon/KDiskMark")
(synopsis "Simple disk benchmark tool")
(description "KDiskMark is an HDD and SSD benchmark tool. KDiskMark