aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-03-01 19:41:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-03 21:27:53 +0100
commit5528f9e8f09f4a63b40647d61ec100c4c5326b3b (patch)
tree01aafb22aafb6813602813a51d926ed771285b88 /gnu
parente44da58c16f8c0dd8d9fb80f38f3e86a08fa22f9 (diff)
downloadguix-5528f9e8f09f4a63b40647d61ec100c4c5326b3b.tar
guix-5528f9e8f09f4a63b40647d61ec100c4c5326b3b.tar.gz
gnu: Add java-biojava-phylo-4.0.
* gnu/packages/bioinformatics.scm (java-biojava-phylo-4.0): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2f5413b35e..37647a9b9b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12270,3 +12270,39 @@ contains
(sha256
(base32
"13675f6y9aqi7bi2lk3s1z7a22ynccjiqwa8izh7p97xi9wsfmd8"))))))
+
+(define-public java-biojava-phylo-4.0
+ (package (inherit java-biojava-core-4.0)
+ (name "java-biojava-phylo")
+ (build-system ant-build-system)
+ (arguments
+ `(#:jdk ,icedtea-8
+ #:jar-name "biojava-phylo.jar"
+ #:source-dir "biojava-phylo/src/main/java/"
+ #:test-dir "biojava-phylo/src/test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "biojava-phylo/src/main/resources"
+ "build/classes")
+ #t))
+ (add-before 'check 'copy-test-resources
+ (lambda _
+ (copy-recursively "biojava-phylo/src/test/resources"
+ "build/test-classes")
+ #t)))))
+ (propagated-inputs
+ `(("java-log4j-api" ,java-log4j-api)
+ ("java-log4j-core" ,java-log4j-core)
+ ("java-slf4j-api" ,java-slf4j-api)
+ ("java-slf4j-simple" ,java-slf4j-simple)
+ ("java-biojava-core" ,java-biojava-core-4.0)
+ ("java-forester" ,java-forester-1.005)))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)))
+ (home-page "http://biojava.org")
+ (synopsis "Biojava interface to the forester phylogenomics library")
+ (description "The phylo module provides a biojava interface layer to the
+forester phylogenomics library for constructing phylogenetic trees.")))