aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-12 12:29:28 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-13 16:08:10 -0500
commit51d2b76529def12628fb124cbbe98ffe407e2145 (patch)
tree43e4da88ae20e95d8bb536850f30c8c041f60306 /gnu
parentf223f773a4e52d17643191c667ed3eef6270cb09 (diff)
downloadguix-51d2b76529def12628fb124cbbe98ffe407e2145.tar
guix-51d2b76529def12628fb124cbbe98ffe407e2145.tar.gz
gnu: icedove-wayland: Use gexps.
* gnu/packages/gnuzilla.scm (icedove/wayland) [inputs]: Set to the empty list. [arguments]: Use gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 150481f1dc..de6db9ddfb 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1420,37 +1420,30 @@ Thunderbird. It supports email, news feeds, chat, calendar and contacts.")
(package
(inherit icedove)
(name "icedove-wayland")
- (native-inputs '())
- (inputs
- `(("bash" ,bash-minimal)
- ("icedove" ,icedove)))
(build-system trivial-build-system)
(arguments
- '(#:modules ((guix build utils))
- #:builder
- (begin
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(begin
(use-modules (guix build utils))
- (let* ((bash (assoc-ref %build-inputs "bash"))
- (icedove (assoc-ref %build-inputs "icedove"))
- (out (assoc-ref %outputs "out"))
- (exe (string-append out "/bin/icedove")))
+ (let* ((exe (string-append #$output "/bin/icedove")))
(mkdir-p (dirname exe))
-
(call-with-output-file exe
(lambda (port)
(format port "#!~a
MOZ_ENABLE_WAYLAND=1 exec ~a $@"
- (string-append bash "/bin/bash")
- (string-append icedove "/bin/icedove"))))
+ #$(file-append bash-minimal "/bin/bash")
+ #$(file-append icedove "/bin/icedove"))))
(chmod exe #o555)
-
;; Provide the manual and .desktop file.
- (copy-recursively (string-append icedove "/share")
- (string-append out "/share"))
- (substitute* (string-append
- out "/share/applications/icedove.desktop")
- ((icedove) out))
- #t))))))
+ (copy-recursively (string-append #$icedove "/share")
+ (string-append #$output "/share"))
+ (substitute* (string-append #$output
+ "/share/applications/icedove.desktop")
+ ((#$icedove) #$output))))))
+ (native-inputs '())
+ (inputs '())))
(define-public firefox-decrypt
(package