aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-16 15:11:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:10 +0100
commit51446076cafb375d7115fc455abf813643c322d6 (patch)
treeeeea218bb0b137c15aa41114a2b5a5b26e6356d8 /gnu
parent8cea282efe5caf9dda2980422e789a7e013b816a (diff)
downloadguix-51446076cafb375d7115fc455abf813643c322d6.tar
guix-51446076cafb375d7115fc455abf813643c322d6.tar.gz
gnu: python-asdf: Update to 3.2.0.
* gnu/packages/astronomy.scm (python-asdf): Update to 3.2.0. [arguments] <#:phases>: Replace 'fix-tests-setup with 'patch-pyprojectct-toml phase and add one more substitution rule. [propagated-inputs]: Remove python-asdf-unit-schemas. Change-Id: I9e7a0282ed0a9eb82a20988762792e10ae33496b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a558e0bbac..9ca12dd9e9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4418,13 +4418,13 @@ between image and reference catalogs. Currently only aligning images with
(define-public python-asdf
(package
(name "python-asdf")
- (version "3.1.0")
+ (version "3.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asdf" version))
(sha256
- (base32 "0fa6y3gmqc0y3nz0h68vq3a84pvx6gc5zp33wg8a4n9b4kipm464"))))
+ (base32 "1wj556g15gwp6ir5hg083l15sifdsf23giqkx0jbn4lgdwjffbgr"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -4432,12 +4432,15 @@ between image and reference catalogs. Currently only aligning images with
#~(list "-n" "auto" "-p" "no:legacypath")
#:phases
#~(modify-phases %standard-phases
- ;; ImportError: Error importing plugin " no:legacypath": No module
- ;; named ' no:legacypath'
- (add-before 'check 'fix-tests-setup
+ (add-after 'unpack 'patch-pypojrect-toml
(lambda _
(substitute* "pyproject.toml"
- ((".*:legacypath.*") "")))))))
+ ;; ImportError: Error importing plugin " no:legacypath": No
+ ;; module named ' no:legacypath'
+ ((".*:legacypath.*") "")
+ ;; TypeError: Configuration.__init__() got an unexpected
+ ;; keyword argument 'version_file'
+ (("version_file = \"asdf/_version.py\"") "")))))))
(native-inputs
(list python-fsspec
python-packaging
@@ -4451,7 +4454,6 @@ between image and reference catalogs. Currently only aligning images with
(propagated-inputs
(list python-asdf-standard
python-asdf-transform-schemas
- python-asdf-unit-schemas
python-attrs ;; for vendorized jsonschema
python-importlib-metadata
python-jmespath