aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJorge Acereda <jacereda@gmail.com>2024-06-29 19:52:44 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-26 21:57:54 +0900
commit4fcbb5787ccc0ad6818fda6faba92afed297da00 (patch)
tree6ba8ace4b823d29ab1176ebc4125756a8a7e80fd /gnu
parent4818404bb41687249d9a7004cf350575de9970ab (diff)
downloadguix-4fcbb5787ccc0ad6818fda6faba92afed297da00.tar
guix-4fcbb5787ccc0ad6818fda6faba92afed297da00.tar.gz
gnu: Add decker.
Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/decker.scm65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 82bd24942b..979e6bad74 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -235,6 +235,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/debug.scm \
%D%/packages/dejagnu.scm \
%D%/packages/dezyne.scm \
+ %D%/packages/decker.scm \
%D%/packages/dhall.scm \
%D%/packages/dico.scm \
%D%/packages/dictionaries.scm \
diff --git a/gnu/packages/decker.scm b/gnu/packages/decker.scm
new file mode 100644
index 0000000000..fdea8ad272
--- /dev/null
+++ b/gnu/packages/decker.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Jorge Acereda <jacereda@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (gnu packages decker)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages vim)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public decker
+ (package
+ (name "decker")
+ (version "1.49")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnEarnest/Decker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hwi62g5wg7zxj98j3civz42za133jq3mz8c0mapqnkn0xnb0qa8"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "COMPILER=" #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'build
+ (lambda* (#:key parallel-build? #:allow-other-keys)
+ (let ((job-count (if parallel-build?
+ (parallel-job-count)
+ 1)))
+ (invoke "make" "lilt" "decker"
+ "-j" (number->string job-count))))))))
+ (native-inputs (list xxd))
+ (inputs (list (sdl-union (list sdl2-image sdl2))))
+ (home-page "http://beyondloom.com/decker/")
+ (synopsis "Multimedia sketchpad")
+ (description
+ "Decker is a multimedia platform for creating and sharing interactive
+documents, with sound, images, hypertext, and scripted behavior.")
+ (license license:expat)))