aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-15 13:12:33 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-16 23:30:49 +0300
commit4dd316cd82ff431845417ea2fc3047cacc95f0e4 (patch)
tree103873af55e7045597a0094ed320f68ac92702b0 /gnu
parenta3ffb920f14cd0d31d1e7067e11dc523fe380996 (diff)
downloadguix-4dd316cd82ff431845417ea2fc3047cacc95f0e4.tar
guix-4dd316cd82ff431845417ea2fc3047cacc95f0e4.tar.gz
gnu: magic-wormhole-mailbox-server: Fix build.
* gnu/packages/magic-wormhole.scm (magic-wormhole-mailbox-server): Fix build. [native-inputs]: Add "python-setuptools" and "python-wheel". Sort alphabetically. Change-Id: Id0af4aebbe3560a58483846d889955c2748ea4da Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/magic-wormhole.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
index dbb943c5c6..f4d70229ba 100644
--- a/gnu/packages/magic-wormhole.scm
+++ b/gnu/packages/magic-wormhole.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2024 normally_js <normally_js@posteo.net>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 TakeV <takev@disroot.org>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -45,7 +47,10 @@
"1yw8i8jv5iv1kkz1aqimskw7fpichjn6ww0fq0czbalwj290bw8s"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-mock python-pytest))
+ (list python-mock
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-attrs
python-autobahn