aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 22:09:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:00 +0100
commit4ac55d72594117b095a4774bb6fb287db7e6a32e (patch)
tree38ee6ac2ba684dfb556634e84ba9da27557d5ef8 /gnu
parent294d3fde530b96a3871fa6b7a6821f09d9798010 (diff)
downloadguix-4ac55d72594117b095a4774bb6fb287db7e6a32e.tar
guix-4ac55d72594117b095a4774bb6fb287db7e6a32e.tar.gz
gnu: Remove go-github-com-aws-sdk.
* gnu/packages/golang-web.scm (go-github-com-aws-sdk): Delete variable. Change-Id: I5901914bc355c1eef472230646b2fbf69fa9650c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 2b72cb3423..a73a3ac23b 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -227,36 +227,6 @@ the parse trees produced by the html package.")
connections from a single physical connection.")
(license license:expat)))
-(define-public go-github-com-aws-sdk
- (package
- (name "go-github-com-aws-sdk")
- (version "1.35.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aws/aws-sdk-go")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1ky5lw2s2zpslnnqcs6hgsrwvwbxwgflb5jwf16dd4aga3vrg10c"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/aws/aws-sdk-go/aws"
- #:unpack-path "github.com/aws/aws-sdk-go"))
- (propagated-inputs
- (list go-github-com-go-sql-driver-mysql
- go-github-com-jmespath-go-jmespath
- go-github-com-pkg-errors
- go-golang-org-x-net))
- (home-page "https://github.com/aws/aws-sdk-go")
- (synopsis "Library to access Amazon Web Services (AWS)")
- (description
- "This is the official AWS SDK for the Go programming language.")
- (license license:asl2.0)))
-
-;; XXX: This package might be a duplicate of go-github-com-aws-sdk, it's not
-;; in use anywhere. Keep it here for the farther review.
(define-public go-github-com-aws-aws-sdk-go
(package
(name "go-github-com-aws-aws-sdk-go")