aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:48 +0200
commit479200d4b77e8c28e3b3c54b752bdfa4d978bdf0 (patch)
tree0d4322e83f02edfc0ee849ced80d46e6092e6a3b /gnu
parente5fb63bd52b9db8c803723de797671b6870fb1c6 (diff)
downloadguix-479200d4b77e8c28e3b3c54b752bdfa4d978bdf0.tar
guix-479200d4b77e8c28e3b3c54b752bdfa4d978bdf0.tar.gz
gnu: Add texlive-tex-locale.
* gnu/packages/tex.scm (texlive-tex-locale): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 22cff6e5db..a2d1fde9e8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97709,6 +97709,29 @@ indexing interface provided by the @code{glossaries} package.")
at the bottom to the right of the page number.")
(license license:lppl1.3+)))
+(define-public texlive-tex-locale
+ (package
+ (name "texlive-tex-locale")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/tex-locale/"
+ "source/latex/tex-locale/"
+ "tex/generic/tex-locale/"
+ "tex/latex/tex-locale/")
+ (base32
+ "0h7sl172flri87cbpygabkhk2qlrng3cwkyk71hz8289qx4g0wpr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tex-locale")
+ (synopsis "Localisation support for TeX and LaTeX documents")
+ (description
+ "This package uses both @code{tracklang} and @code{texosquery} to look up the
+locale information from the operating system and provide commands that can
+access locale-dependent information, such as the currency symbol and decimal
+separator.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar