aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-06 09:57:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 11:20:19 +0100
commit46f84cdec5ff264557d86dd80f7859bc1aa1a3b5 (patch)
tree9e551813068ad634a4ebe8540f8e83b895cad341 /gnu
parent71b2834ab00dad4b1363d7771deb2d749ce5e04d (diff)
downloadguix-46f84cdec5ff264557d86dd80f7859bc1aa1a3b5.tar
guix-46f84cdec5ff264557d86dd80f7859bc1aa1a3b5.tar.gz
gnu: go-github-com-alecthomas-repr: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-alecthomas-repr): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I0cc0ea79264d2365e1e1bf910720c956c527c23f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b30a35506a..1155affd3d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -587,6 +587,33 @@ structs. The approach is similar to how other marshallers work in Golang,
\"unmarshalling\" an instance of a grammar into a struct.")
(license license:expat)))
+(define-public go-github-com-alecthomas-repr
+ (package
+ (name "go-github-com-alecthomas-repr")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/repr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ikvl78dighkn87bxk6gki4wcz9f138n7kbqkagj5vbdb690yjkl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/alecthomas/repr"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/alecthomas/repr/")
+ (synopsis "Represent Go values in an almost direct form")
+ (description
+ "This package attempts to represent Go values in a form that can be used
+almost directly in Go source code.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-template
;; No release, see <https://github.com/alecthomas/template/issues/7>.
(let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4db1e4184b..ba91abc6c9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6734,31 +6734,6 @@ other files). If stdout is not a terminal, colour formatting will be
stripped.")
(license license:expat)))
-(define-public go-github-com-alecthomas-repr
- (package
- (name "go-github-com-alecthomas-repr")
- (version "0.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/repr")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ikvl78dighkn87bxk6gki4wcz9f138n7kbqkagj5vbdb690yjkl"))))
- (build-system go-build-system)
- (arguments
- `(#:go ,go-1.18
- #:import-path "github.com/alecthomas/repr"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (home-page "https://github.com/alecthomas/repr/")
- (synopsis "Represent Go values in an almost direct form")
- (description "This package attempts to represent Go values in a form that
-can be used almost directly in Go source code.")
- (license license:expat)))
-
(define-public go-github-com-muesli-reflow-wordwrap
(package
(name "go-github-com-muesli-reflow-wordwrap")