aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:01:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:01:13 +0200
commit46d3c6123ff8328f4b7c27676b4e0f883c80e956 (patch)
tree353e8962d394a459302a1e323ef24e62a05b82f8 /gnu
parentd0aba39186599e5a605889612d31b7a1fa48f6be (diff)
downloadguix-46d3c6123ff8328f4b7c27676b4e0f883c80e956.tar
guix-46d3c6123ff8328f4b7c27676b4e0f883c80e956.tar.gz
gnu: Add texlive-pxchfon.
* gnu/packages/tex.scm (texlive-pxchfon): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6613f531c2..cc2ea8ef66 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15110,6 +15110,32 @@ a few user commands to assist in creating Japanese documents using
@code{(u)pLaTeX.}")
(license license:expat)))
+(define-public texlive-pxchfon
+ (package
+ (name "texlive-pxchfon")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/platex/pxchfon/" "fonts/sfd/pxchfon/"
+ "fonts/tfm/public/pxchfon/"
+ "fonts/vf/public/pxchfon/"
+ "tex/platex/pxchfon/")
+ (base32
+ "0pvhgcv6rxp2lnscsh9k3z907114p09ja3frcy5276is21d6sdrj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pxchfon")
+ (synopsis "Japanese font setup for pLaTeX and upLaTeX")
+ (description
+ "This package enables users to declare in their document which physical
+fonts should be used for the standard Japanese (logical) fonts of pLaTeX and
+upLaTeX. Font setup is realized by changing the font mapping of dvipdfmx, and
+thus users can use any (monospaced) physical fonts they like, once they
+properly install this package, without creating helper files for each new
+font. This package also supports setup for the fonts used in the
+@code{japanese-otf} package.")
+ (license license:expat)))
+
(define-public texlive-pwebmac
(package
(name "texlive-pwebmac")