aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:34:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:28:19 +0000
commit4609bea87ca61cbb4467f02ee084a1a1468e1529 (patch)
treeea562d609be2639633b07d10199e2706b28764a6 /gnu
parentf9ead8f7a832eb0b02b78de5ff379bfa0a1fc310 (diff)
downloadguix-4609bea87ca61cbb4467f02ee084a1a1468e1529.tar
guix-4609bea87ca61cbb4467f02ee084a1a1468e1529.tar.gz
gnu: go-github-com-bmizerany-perks-quantile: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-bmizerany-perks-quantile): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I215d8f1f2710bd21ad9a251e4cb029064a0968f6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ee63a78cf7..51ea851139 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -89,6 +89,30 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-bmizerany-perks-quantile
+ (package
+ (name "go-github-com-bmizerany-perks-quantile")
+ (version "0.0.0-20230307044200-03f9df79da1e")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bmizerany/perks")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f2a99v3618bz2mf61iwhdjm3xi1gam6v4apqgcrz71gj7ba9943"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:unpack-path "github.com/bmizerany/perks"
+ #:import-path "github.com/bmizerany/perks/quantile"))
+ (home-page "https://github.com/bmizerany/perks")
+ (synopsis "Library for computing quantiles")
+ (description
+ "Perks contains the Go package @code{quantile} that computes approximate
+quantiles over an unbounded data stream within low memory and CPU bounds.")
+ (license license:bsd-2)))
+
(define-public go-github-com-burntsushi-toml
(package
(name "go-github-com-burntsushi-toml")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5a2972427c..089b54d5a5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7944,30 +7944,6 @@ the library more lightweight.")
matching and globbing with support for \"doublestar\" patterns.")
(license license:expat)))
-(define-public go-github-com-bmizerany-perks-quantile
- (package
- (name "go-github-com-bmizerany-perks-quantile")
- (version "0.0.0-20230307044200-03f9df79da1e")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bmizerany/perks")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1f2a99v3618bz2mf61iwhdjm3xi1gam6v4apqgcrz71gj7ba9943"))))
- (build-system go-build-system)
- (arguments
- (list #:unpack-path "github.com/bmizerany/perks"
- #:import-path "github.com/bmizerany/perks/quantile"))
- (home-page "https://github.com/bmizerany/perks")
- (synopsis "Library for computing quantiles")
- (description
- "Perks contains the Go package @code{quantile} that computes approximate
-quantiles over an unbounded data stream within low memory and CPU bounds.")
- (license license:bsd-2)))
-
(define-public go-github-com-dlclark-regexp2
(package
(name "go-github-com-dlclark-regexp2")