aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 14:52:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:53 +0200
commit43aec15ba22b8707b78546d8487a16ee2c58525c (patch)
treec626f2d0e6be4ec445b164bcc7a613f1d42c786e /gnu
parent69b3c53e29508cf49477eb04152d0794bbb3bdb7 (diff)
downloadguix-43aec15ba22b8707b78546d8487a16ee2c58525c.tar
guix-43aec15ba22b8707b78546d8487a16ee2c58525c.tar.gz
gnu: Add texlive-sauerj.
* gnu/packages/tex.scm (texlive-sauerj): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ac2212bb6b..2d5fb4987a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6394,6 +6394,32 @@ rectangles, which may or may not contain a title bar or text (the title bar
may itself contain text).")
(license license:lppl1.3+)))
+(define-public texlive-sauerj
+ (package
+ (name "texlive-sauerj")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/sauerj/" "source/latex/sauerj/"
+ "tex/latex/sauerj/")
+ (base32
+ "03dmw150qcravzndikijhq2a89sjdplxgi93fx0zxln2l4flvz5k")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/sauerj")
+ (synopsis "Bundle of utilities by Jonathan Sauer")
+ (description
+ "The bundle consists of:
+@itemize
+@item a tool for collecting text for later re-use,
+@item a tool for typesetting the meta-information within a text,
+@item a tool for use in constructing macros with multiple optional parameters,
+@item a package for multiple column parallel texts,
+@item a tool for processing key-value structured lists,
+@item macros for typesetting a number as a German-language string.
+@end itemize")
+ (license license:lppl)))
+
(define-public texlive-selinput
(package
(name "texlive-selinput")