aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-29 10:52:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:15 +0200
commit407fcd510b1bbcd94a7bc1a6f7deedcfc9789003 (patch)
tree98676ffef482c44a6cc43812a36f1f61ed56a19c /gnu
parent859953f60a8a9c9f3e2d6fed13e26f90ea20f016 (diff)
downloadguix-407fcd510b1bbcd94a7bc1a6f7deedcfc9789003.tar
guix-407fcd510b1bbcd94a7bc1a6f7deedcfc9789003.tar.gz
gnu: Add python-colorcet.
* gnu/packages/python-xyz.scm (python-colorcet): New variable. Change-Id: I8b3f6d9a132d028f56330308b034d263e162f0f9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c30035952d..278a0ecd9b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1033,6 +1033,29 @@ It uses a plain-text database, a location-independent library, and features
git integration, command-line support, and a curses-based TUI.")
(license license:expat)))
+(define-public python-colorcet
+ (package
+ (name "python-colorcet")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "colorcet" version))
+ (sha256
+ (base32 "1sx4m5xbz1k8bm8cr2f3x21dip167k7c1nv35npqla52h76v6899"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-nbval
+ python-packaging
+ python-pytest
+ python-pytest-cov
+ python-pytest-mpl))
+ (home-page "https://colorcet.holoviz.org/")
+ (synopsis "Collection of perceptually uniform colormaps")
+ (description "Colorcet is a collection of perceptually accurate 256-color
+colormaps for use with Python plotting programs like Bokeh, Matplotlib,
+HoloViews, and Datashader.")
+ (license license:cc-by4.0)))
+
(define-public python-colored
(package
(name "python-colored")