aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRutherther <rutherther@protonmail.com>2024-09-13 11:42:04 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-12 19:23:33 +0200
commit3f09b05d8d402d306105ef5ac63f8b6dc49c5e3a (patch)
treea320d99d79435ee55e60f86740b590aada44ccf9 /gnu
parentce8872fe9dbce401fef140d0f3e8feea85d9570b (diff)
downloadguix-3f09b05d8d402d306105ef5ac63f8b6dc49c5e3a.tar
guix-3f09b05d8d402d306105ef5ac63f8b6dc49c5e3a.tar.gz
gnu: make-libstdc++-arm-none-eabi: output libstdc++ to arm-none-eabi.
The libstdc++ made for arm-none-eabi puts the contents into "lib" folder, but that's unexpected when the resulting toolchain is a cross toolchain. The folder should be "arm-none-eabi/lib", that's the path added to CROSS_C_LIBRARY_PATH * gnu/packages/embedded.scm (make-libstdc++-arm-none-eabi): [arguments]<#:configure-flags>: Point --libdir to arm-none-eabi/lib. [arguments]<#:strip-directories>: Set to arm-none-eabi/lib. Change-Id: Ia8b867a1c6ebeedeae9564e0a6a1e0401b35bd5b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/embedded.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index a7ba9ebe98..2a482f7e52 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -493,9 +493,14 @@ embedded-7-branch/")
"--disable-tls"
"--disable-plugin"
"--with-newlib"
+ ,(string-append "--libdir="
+ (assoc-ref %outputs "out")
+ "/arm-none-eabi/lib")
,(string-append "--with-gxx-include-dir="
(assoc-ref %outputs "out")
- "/arm-none-eabi/include/c++")))))
+ "/arm-none-eabi/include/c++")))
+ ((#:strip-directories _ #f)
+ ''("arm-none-eabi/lib"))))
(native-inputs
`(("newlib" ,newlib)
("xgcc" ,xgcc)