aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2023-05-08 23:55:35 +0200
committerAndrew Tropin <andrew@trop.in>2023-06-14 13:41:59 +0400
commit39a02c5c4eefb555257cd2fcda0f89574b857985 (patch)
treea4e91bb8200acf093a98fcafc988944cc969683c /gnu
parent2dd3e35fc97718070e1511ca25d2aa28aeafbbc0 (diff)
downloadguix-39a02c5c4eefb555257cd2fcda0f89574b857985.tar
guix-39a02c5c4eefb555257cd2fcda0f89574b857985.tar.gz
gnu: pipewire: Update to 0.3.70.
* gnu/packages/linux.scm (pipewire): Update to 0.3.70. [inputs]: Add glib. [arguments]: Do not install rlimits. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 304085960d..75252ea278 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9175,7 +9175,7 @@ types and interfaces and translates so that the X server can use them.")
(define-public pipewire
(package
(name "pipewire")
- (version "0.3.63")
+ (version "0.3.70")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -9184,18 +9184,20 @@ types and interfaces and translates so that the X server can use them.")
(file-name (git-file-name name version))
(sha256
(base32
- "1pkngynvhxc6iyv75gsyqjy18ky4si9dhvpavb9xwq5xj71nj0hr"))))
+ "1n74rrbwymm89ri4daa4v092f4b81wrak4vg685xfz2wl89p64n6"))))
(build-system meson-build-system)
(arguments
(list
#:configure-flags
#~(list (string-append "-Dudevrulesdir=" #$output "/lib/udev/rules.d")
- "-Dsystemd=disabled"
+ "-Dman=enabled"
+ "-Drlimits-install=false"
"-Dsession-managers=[]"
"-Dsysconfdir=/etc"
- "-Dman=enabled")))
+ "-Dsystemd=disabled")))
(native-inputs
- (list pkg-config
+ (list `(,glib "bin")
+ pkg-config
python-docutils))
(inputs (list alsa-lib
avahi