aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2021-09-27 02:20:19 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-15 17:55:50 +0100
commit37e6f028804aa63648534e1f533913b5c93265f8 (patch)
tree9b1bc9df6affb01e9f905e4e98a8cc8e276f6fad /gnu
parent93730073219fa3da6558c90ac9b14064727f4916 (diff)
downloadguix-37e6f028804aa63648534e1f533913b5c93265f8.tar
guix-37e6f028804aa63648534e1f533913b5c93265f8.tar.gz
gnu: Add python-cons.
* gnu/packages/python-xyz.scm (python-cons): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ece7e7bf2f..3462704223 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27421,6 +27421,30 @@ function implementations based on the types of the arguments.")
symbolic expressions in pure Python using the technique of logical unification.")
(license license:bsd-3)))
+(define-public python-cons
+ (package
+ (name "python-cons")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cons" version))
+ (sha256
+ (base32
+ "0w9giq196wps7mbm47c4shdzs5yvwvqajqzkim2p92i51sm5qgvm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest-6)
+ ("python-toml" ,python-toml)))
+ (propagated-inputs
+ `(("python-logical-unification" ,python-logical-unification)))
+ (home-page "https://github.com/pythological/python-cons")
+ (synopsis "Cons cell data structures and related algorithms for Python")
+ (description
+ "This library implements algorithms and data structures for Lisp-style
+cons cells in Python.")
+ (license license:lgpl3+)))
+
(define-public date2name
(let ((commit "6c8f37277e8ec82aa50f90b8921422be30c4e798")
(revision "1"))