aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-03 15:32:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 12:33:59 -0500
commit33f80689a987049928a03649bfeb25e6d77aa764 (patch)
tree8c61dc98268c28d41a4b18bc5d3782798e3eb108 /gnu
parent219445154495d4923280e87fe5d95307f330f445 (diff)
downloadguix-33f80689a987049928a03649bfeb25e6d77aa764.tar
guix-33f80689a987049928a03649bfeb25e6d77aa764.tar.gz
gnu: Add python-robotframework-stacktrace.
* gnu/packages/python-xyz.scm (python-robotframework-stacktrace): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4d6b63599..18db8751d1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4511,6 +4511,35 @@ process automation (RPA).")
utility, a static analysis tool (linter) for Robot Framework source files.")
(license license:asl2.0))))
+(define-public python-robotframework-stacktrace
+ (package
+ (name "python-robotframework-stacktrace")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "robotframework-stacktrace" version))
+ (sha256
+ (base32 "19gnwr7da1zz9clhwsmvqfjf02d195i61lzpq4253dcsgrpb6v79"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The test suite fails (see:
+ ;; https://github.com/MarketSquare/robotframework-stacktrace/issues/4).
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "tests"
+ (invoke "python" "-m" "robot" "."))))))))
+ (propagated-inputs (list python-robotframework))
+ (home-page "https://github.com/MarketSquare/robotframework-stacktrace")
+ (synopsis "Robot Framework listener to print a stack trace on error")
+ (description "StackTrace is a Robot Framework listener that prints a stack
+trace directly to the terminal to ease debugging.")
+ (license license:asl2.0)))
+
(define-public python-robotframework-sshlibrary
(package
(name "python-robotframework-sshlibrary")