aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-19 12:52:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 22:47:22 +0100
commit31fed85aa853cb409166f587fc82a358076b578e (patch)
tree3f9d734650ddabb7357137c3a8b532da873aff35 /gnu
parentec23b6ec0449526d7773c392505efb5729b2afd6 (diff)
downloadguix-31fed85aa853cb409166f587fc82a358076b578e.tar
guix-31fed85aa853cb409166f587fc82a358076b578e.tar.gz
gnu: Add go-github-com-xi2-xz.
* gnu/packages/golang-compression.scm (go-github-com-xi2-xz): New variable. Change-Id: I794886d82f532a626599ca6f07a1ce7e694bea04
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-compression.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index a6c0410051..c4465f1bcd 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -331,6 +331,34 @@ decompressing data. The package is completely written in Go and doesn't have
any dependency on any C code.")
(license license:bsd-3)))
+(define-public go-github-com-xi2-xz
+ (package
+ (name "go-github-com-xi2-xz")
+ (version "0.0.0-20171230120015-48954b6210f8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xi2/xz")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "178r0fa2dpzxf0sabs7dn0c8fa7vs87zlxk6spkn374ls9pir7nq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xi2/xz"))
+ (home-page "https://github.com/xi2/xz")
+ (synopsis "Native Golang XZ decompression package")
+ (description
+ "This package implements a native XZ decompression in Golang.")
+ ;; This package is a modified version of XZ Embedded
+ ;; <http://tukaani.org/xz/embedded.html>: 0BSD
+ ;;
+ ;; The contents of the testdata directory are modified versions of the
+ ;; test files from XZ Utils <http://tukaani.org/xz/>: 0BSD
+ (license license:public-domain)))
+
;;;
;;; Executables:
;;;