aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-05-09 15:35:40 +0100
committerChristopher Baines <mail@cbaines.net>2024-05-13 12:01:46 +0100
commit31d1cc82b325d8b17e21c5a22e9aea6c24cffe90 (patch)
treee11cb6bd04a78d22a226041e5e562b6cbb2b186c /gnu
parent08360a2cd0f1c447c9ad25bef8ed317abcdb0c91 (diff)
downloadguix-31d1cc82b325d8b17e21c5a22e9aea6c24cffe90.tar
guix-31d1cc82b325d8b17e21c5a22e9aea6c24cffe90.tar.gz
gnu: nss/fixed: Tweak performance test.
As I'm seeing this test fail with results of 5 to 7 seconds. * gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher time threshold. Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/nss.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..80bf627583 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@ security standards.")
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
+ ;; This specific test is looking at performance "now
+ ;; verify that we can quickly dump a database", and
+ ;; we're not testing performance here (especially
+ ;; since we're using faketime), so raise the
+ ;; threshold
+ (substitute* "nss/tests/dbtests/dbtests.sh"
+ ((" -lt 5") " -lt 50"))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To