aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:29:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:38 +0100
commit2ecd4e3bfdd6fe2d2ca3acbf50d6917af905fee0 (patch)
treedefa1a8f450d52ee587c918fce9baa2347c954d4 /gnu
parentd7937243bad6ffb204b98521c8cdda0f7864bf5a (diff)
downloadguix-2ecd4e3bfdd6fe2d2ca3acbf50d6917af905fee0.tar
guix-2ecd4e3bfdd6fe2d2ca3acbf50d6917af905fee0.tar.gz
gnu: Add r-emojifont.
* gnu/packages/cran.scm (r-emojifont): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cddf78951d..2101489577 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16517,3 +16517,28 @@ will be converted into polygons or raster images, hence after the plot has
been created, it no longer relies on the font files. No external software
such as Ghostscript is needed to use this package.")
(license license:asl2.0)))
+
+(define-public r-emojifont
+ (package
+ (name "r-emojifont")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "emojifont" version))
+ (sha256
+ (base32
+ "1cdrrl3hvrs8rskyy6zgr7q2mmg8yb9k8sld1m64zsp7y009g19k"))))
+ (properties `((upstream-name . "emojifont")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-proto" ,r-proto)
+ ("r-showtext" ,r-showtext)
+ ("r-sysfonts" ,r-sysfonts)))
+ (home-page "https://guangchuangyu.github.io/emojifont")
+ (synopsis "Emoji and Font Awesome in R graphics")
+ (description
+ "This package enables the use of emoji and the Font Awesome glyphs in
+both base and ggplot2 graphics.")
+ (license license:artistic2.0)))