aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-11 22:08:30 -0500
committerjgart <jgart@dismail.de>2024-07-11 22:10:36 -0500
commit2d6a3799fcda5c017f653c6e96b91964b07a7ee0 (patch)
tree8229ea1a2d9cfdfa3d6bf69a0c63774bb8abfb9b /gnu
parentdd1b8840ace3c964f293f3ee2444738d142922ee (diff)
downloadguix-2d6a3799fcda5c017f653c6e96b91964b07a7ee0.tar
guix-2d6a3799fcda5c017f653c6e96b91964b07a7ee0.tar.gz
gnu: python-colorlog: Use new style.
* gnu/packages/python-xyz.scm (python-colorlog): Use new style. Change-Id: Id31d34d9c09330f7a5aa723ca1a1352b6736d875
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 264fd3edd5..1bf07d3c26 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,7 +99,7 @@
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
-;;; Copyright © 2021, 2023 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2023-2024 jgart <jgart@dismail.de>
;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
@@ -2113,13 +2113,14 @@ implementation for the Telegram Bot API.")
(base32 "1s7x0v872h8aks8xp01wmv6hzisxqjrh1svbbcycir0980h76krl"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
(native-inputs
(list python-pytest))
(home-page "https://github.com/borntyping/python-colorlog")