aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-04-23 13:25:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-06 11:24:57 +0200
commit2c52bbd16d5e12f7c67e3d26c593af64365ed4ee (patch)
tree0644525963f8dc7f64485c82b9855eaa4d554a49 /gnu
parent458cd1e1d807300b9feee0c68d6209b12aeaa579 (diff)
downloadguix-2c52bbd16d5e12f7c67e3d26c593af64365ed4ee.tar
guix-2c52bbd16d5e12f7c67e3d26c593af64365ed4ee.tar.gz
gnu: Add r-detectseparation.
* gnu/packages/cran.scm (r-detectseparation): New variable. Change-Id: I6c795719c22a6ff929785e799f749ce053e83fbe
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 645f9df777..209f244331 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4253,6 +4253,38 @@ categorical and continuous (time series) data, otherwise known as dependent
mixture models.")
(license license:gpl2+)))
+(define-public r-detectseparation
+ (package
+ (name "r-detectseparation")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "detectseparation" version))
+ (sha256
+ (base32 "05z3p1z5mhmdj5qdknz1b8f6fwbghzckl88pv79v59cfwpbvgmz8"))))
+ (properties `((upstream-name . "detectseparation")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-lpsolveapi r-pkgload r-roi r-roi-plugin-lpsolve))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ikosmidis/detectseparation")
+ (synopsis
+ "Detect and check for separation and infinite maximum likelihood estimates")
+ (description
+ "This package provides pre-fit and post-fit methods for detecting separation
+and infinite maximum likelihood estimates in generalized linear models with
+categorical responses. The pre-fit methods apply on binomial-response generalized
+liner models such as logit, probit and cloglog regression, and can be directly
+supplied as fitting methods to the @code{glm()} function. The post-fit methods
+apply to models with categorical responses, including binomial-response
+generalized linear models and multinomial-response models, such as baseline
+category logits and adjacent category logits models; for example, the models
+implemented in the brglm2 package. The post-fit methods successively refit the
+model with increasing number of iteratively reweighted least squares iterations,
+and monitor the ratio of the estimated standard error for each parameter to what
+it has been in the first iteration.")
+ (license license:gpl3)))
+
(define-public r-readxl
(package
(name "r-readxl")