aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:33:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:18 +0200
commit251b8ba0bec97d98a13c21bdd1e8868feb997b62 (patch)
treefe74831d961734cf36e11c6d62a8910fabb4f34e /gnu
parent2fc6ae43b5f0eb30795cdf559456398b6c5f8bf4 (diff)
downloadguix-251b8ba0bec97d98a13c21bdd1e8868feb997b62.tar
guix-251b8ba0bec97d98a13c21bdd1e8868feb997b62.tar.gz
gnu: Add texlive-ps2eps.
* gnu/packages/tex.scm (texlive-ps2eps): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 626b44392e..9859ac5fbe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3862,6 +3862,37 @@ and glued together. This will lead to a physical product box.")
(list
(license:fsf-free "https://tug.ctan.org/macros/latex/contrib/gene/productbox/productbox.ins")))))
+(define-public texlive-ps2eps
+ (package
+ (name "texlive-ps2eps")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/bbox.1"
+ "doc/man/man1/bbox.man1.pdf"
+ "doc/man/man1/ps2eps.1"
+ "doc/man/man1/ps2eps.man1.pdf"
+ "scripts/ps2eps/")
+ (base32
+ "1anrvgs0hd3790dwpxqal0c2drjmvh93vnyqap40rvp8axwi0a6n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ps2eps.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/ps2eps")
+ (synopsis "Produce Encapsulated PostScript from PostScript")
+ (description
+ "@command{ps2eps} produces Encapsulated PostScript Files (EPS/EPSF) from
+a one-page PostScript document, or any PostScript document. A correct
+bounding box is calculated for the EPS files and some PostScript command
+sequences that can produce errorneous results on printers are filtered. The
+input is cropped to include just the image contained in the PostScript file.
+The EPS files can then be included into TeX documents.
+
+Included in the distribution is the @command{bbox} program, an application to
+produce bounding box values for Rawppm or Rawpbm format files.")
+ (license license:gpl3+)))
+
(define-public texlive-ptolemaicastronomy
(package
(name "texlive-ptolemaicastronomy")