aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-14 20:09:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:53 +0100
commit226cd42a5ff6cf375dc0b1aa3ab1287fe53e72fc (patch)
tree40718e9f0e57750d81b34699f8c8386c27bc18a4 /gnu
parent424c6fe0a2f151a182ad0f18e60be8887e9b4d8b (diff)
downloadguix-226cd42a5ff6cf375dc0b1aa3ab1287fe53e72fc.tar
guix-226cd42a5ff6cf375dc0b1aa3ab1287fe53e72fc.tar.gz
gnu: go-github-com-dhowett-go-plist: Improve package style.
* gnu/packages/golang.scm (go-github-com-dhowett-go-plist): Fix indentation. Apply new style. Swap inputs to propagated-inputs. [inputs]: Remove go-github-com-jessevdk-go-flags, go-github-com-kr-pretty, go-gopkg-in-check-v1, and go-gopkg-in-yaml-v2. [propagated-inputs]: Add go-github-com-jessevdk-go-flags and go-gopkg-in-check-v1. Change-Id: I01f2d222b72e9d8d52e0f5c1953d36703d03fb6b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm48
1 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index da48d02297..702c9767d4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1738,29 +1738,31 @@ retry strategies, such as fixed delay, backoff delay, and random delay.")
(license license:expat)))
(define-public go-github-com-dhowett-go-plist
- (package
- (name "go-github-com-dhowett-go-plist")
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/DHowett/go-plist")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gcrxkmdj87xq01458asgxvvijrkih74ydbzfmir1p16xr9z0x39"))))
- (build-system go-build-system)
- (arguments `(#:import-path "howett.net/plist"))
- (inputs
- (list go-github-com-jessevdk-go-flags go-github-com-kr-pretty
- go-gopkg-in-check-v1 go-gopkg-in-yaml-v2))
- (home-page "https://github.com/DHowett/go-plist")
- (synopsis "Apple property list transcoder")
- (description "This list transcoder supports encoding/decoding property
-lists (Apple XML, Apple Binary, OpenStep, and GNUStep) from/to arbitrary Go
-types.")
- (license license:giftware)))
+ (package
+ (name "go-github-com-dhowett-go-plist")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DHowett/go-plist")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gcrxkmdj87xq01458asgxvvijrkih74ydbzfmir1p16xr9z0x39"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "howett.net/plist"))
+ (propagated-inputs
+ (list go-github-com-jessevdk-go-flags
+ go-gopkg-in-check-v1))
+ (home-page "https://github.com/DHowett/go-plist")
+ (synopsis "Apple property list transcoder")
+ (description
+ "This list transcoder supports encoding/decoding property lists (Apple
+XML, Apple Binary, OpenStep, and GNUStep) from/to arbitrary Go types.")
+ (license license:giftware)))
(define-public go-github-com-blanu-dust
(package