aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-09-05 00:37:05 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-09-05 00:37:05 -0400
commit20b1613484f512649f919d89285e981998592497 (patch)
treed4599247c59852a214392a6dfc4c5c30990755e3 /gnu
parented95ddeb1e58c314f2e22b4cd35986042f3e2f21 (diff)
downloadguix-20b1613484f512649f919d89285e981998592497.tar
guix-20b1613484f512649f919d89285e981998592497.tar.gz
gnu: python-pygithub: Fix tests.
* gnu/packages/python-xyz.scm (python-pygithub)[native-inputs]: Add nss-certs-for-test. Change-Id: Ib0ee6f1c23302adfec3e8d184cc4afff285012e7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6bbcf9f7b3..16424749bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -186,6 +186,7 @@
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages bioinformatics)
#:use-module (gnu packages build-tools)
+ #:use-module (gnu packages certs)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -7300,7 +7301,7 @@ to deprecate classes, functions or methods.")
(list python-cryptography python-deprecated python-pyjwt
python-pynacl python-requests))
(native-inputs
- (list python-httpretty python-pytest))
+ (list nss-certs-for-test python-httpretty python-pytest))
(home-page "https://pygithub.readthedocs.io/en/latest/")
(synopsis "Python library for the GitHub API")
(description "This library allows managing GitHub resources such as