aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:30:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:56 +0200
commit1a1390ed3063b3d1b21c86a5d323a3001f6f9366 (patch)
treed875d255491a5a040dce6fa9d22e41bc8846a146 /gnu
parent98206c123b1b2b20aa36b9a25154b08077b81337 (diff)
downloadguix-1a1390ed3063b3d1b21c86a5d323a3001f6f9366.tar
guix-1a1390ed3063b3d1b21c86a5d323a3001f6f9366.tar.gz
gnu: Add texlive-matlab-prettifier.
* gnu/packages/tex.scm (texlive-matlab-prettifier): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b638657644..ff97e762a7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4627,6 +4627,27 @@ only unify typesetting of math formulae but also allow to easily adapt
notation if a user prefers to. The semantic layer is split into topics.")
(license license:expat)))
+(define-public texlive-matlab-prettifier
+ (package
+ (name "texlive-matlab-prettifier")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/matlab-prettifier/"
+ "source/latex/matlab-prettifier/"
+ "tex/latex/matlab-prettifier/")
+ (base32
+ "1mr3h2pwz5ghhy3k9c35c6q9k946qzmg7clldmlzlrq3cm685lsh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/matlab-prettifier")
+ (synopsis "Pretty-print Matlab source code")
+ (description
+ "The package extends the facilities of the listings package, to
+pretty-print Matlab and Octave source code. (Note that support of Octave
+syntax is not complete.)")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")