aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:09:35 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:26 +0100
commit1667e151ba28bed7f6d7e905ac6b0868bc1d9d17 (patch)
tree9ae09e53438b2bbc9e3ec62ecd44a87a0582322b /gnu
parent2cd18578e783e4ffba24ae65f78e419615d9746e (diff)
downloadguix-1667e151ba28bed7f6d7e905ac6b0868bc1d9d17.tar
guix-1667e151ba28bed7f6d7e905ac6b0868bc1d9d17.tar.gz
gnu: Remove ocaml4.07-ppx-assert.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-assert): Remove variable. (ocaml-ppx-assert)[properties]: Remove variant. Change-Id: Iba0b987323b8ee3feb2330b1e5eed199856466ee
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 1 insertions, 19 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 96b3d86c7d..9fbb265413 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7232,31 +7232,13 @@ https://github.com/ocaml/ocaml/issues/8563.")
ocaml-ppx-sexp-conv
ocaml-migrate-parsetree
ocaml-ppxlib))
- (properties `((upstream-name . "ppx_assert")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-assert))))
+ (properties `((upstream-name . "ppx_assert")))
(home-page "https://github.com/janestreet/ppx_assert")
(synopsis "Assert-like extension nodes that raise useful errors on failure")
(description "This package contains assert-like extension nodes that raise
useful errors on failure.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-assert
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-assert)
- (version "0.11.0")
- (source
- (janestreet-origin "ppx_assert" version
- "17kd311n0l9f72gblf9kv8i5rghr106w37x4f0m5qwh6nlgl0j9k"))
- (propagated-inputs
- `(("ocaml-base" ,ocaml-base)
- ("ocaml-ppx-compare" ,ocaml-ppx-compare)
- ("ocaml-ppx-here" ,ocaml-ppx-here)
- ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
- ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
- ("ocaml-ppxlib" ,ocaml-ppxlib)))
- (properties `((upstream-name . "ppx_assert"))))))
-
(define-public ocaml-ppx-expect
(package
(name "ocaml-ppx-expect")