aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-23 22:47:39 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-23 23:33:09 +0100
commit12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729 (patch)
tree2c85197829465c6d48075166bd313d6c228508ef /gnu
parentbbb7a00e9a224d812a56c67956efb3e8a840cf0a (diff)
downloadguix-12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729.tar
guix-12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729.tar.gz
gnu: Remove unnecessary closures around `arguments' value.
* gnu/packages/algebra.scm (pari-gp): Remove closure around the value of `arguments'. * gnu/packages/bdb.scm (bdb): Likewise. * gnu/packages/mit-krb5.scm (mit-krb5): Likewise. * gnu/packages/openssl.scm (openssl): Likewise. * gnu/packages/perl.scm (perl): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm39
-rw-r--r--gnu/packages/bdb.scm25
-rw-r--r--gnu/packages/mit-krb5.scm51
-rw-r--r--gnu/packages/openssl.scm47
-rw-r--r--gnu/packages/perl.scm49
5 files changed, 103 insertions, 108 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 84806f9e3a..1fa98d2565 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -120,26 +120,25 @@ extensive test suite.")
("perl" ,perl)
("readline" ,readline)))
(arguments
- (lambda (system)
- `(#:make-flags '("gp")
-;; FIXME: building the documentation requires tex; once this is available,
-;; replace "gp" by "all"
- #:test-target "dobench"
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (readline (assoc-ref inputs "readline"))
- (gmp (assoc-ref inputs "gmp")))
- (zero?
- (system* "./Configure"
- (string-append "--prefix=" out)
- (string-append "--with-readline=" readline)
- (string-append "--with-gmp=" gmp)))))
-;; FIXME: readline and gmp will be detected automatically in the next
-;; stable release
- %standard-phases))))
+ '(#:make-flags '("gp")
+ ;; FIXME: building the documentation requires tex; once this is available,
+ ;; replace "gp" by "all"
+ #:test-target "dobench"
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (readline (assoc-ref inputs "readline"))
+ (gmp (assoc-ref inputs "gmp")))
+ (zero?
+ (system* "./Configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-readline=" readline)
+ (string-append "--with-gmp=" gmp)))))
+ ;; FIXME: readline and gmp will be detected automatically in the next
+ ;; stable release
+ %standard-phases)))
(synopsis "PARI/GP, a computer algebra system for number theory")
(description
"PARI/GP is a widely used computer algebra system designed for fast
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
index c9cdf4af6b..9a626b17d7 100644
--- a/gnu/packages/bdb.scm
+++ b/gnu/packages/bdb.scm
@@ -35,19 +35,18 @@
"1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
(build-system gnu-build-system)
(arguments
- (lambda (system)
- `(#:tests? #f ; no check target available
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "./dist/configure"
- (string-append "--prefix=" out)
- (string-append "CONFIG_SHELL=" (which "bash"))
- (string-append "SHELL=" (which "bash"))))))
- %standard-phases))))
+ '(#:tests? #f ; no check target available
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero?
+ (system* "./dist/configure"
+ (string-append "--prefix=" out)
+ (string-append "CONFIG_SHELL=" (which "bash"))
+ (string-append "SHELL=" (which "bash"))))))
+ %standard-phases)))
(synopsis "db, the Berkeley database")
(description
"Berkeley DB is an embeddable database allowing developers the choice of
diff --git a/gnu/packages/mit-krb5.scm b/gnu/packages/mit-krb5.scm
index 141957697c..fe1170721e 100644
--- a/gnu/packages/mit-krb5.scm
+++ b/gnu/packages/mit-krb5.scm
@@ -42,36 +42,35 @@
("perl" ,perl)
))
(arguments
- (lambda (system)
- `(#:phases
- (alist-replace
- 'unpack
- (lambda* (#:key source #:allow-other-keys)
- (let ((inner
- (substring source
- (string-index-right source #\k)
- (string-index-right source #\-))))
+ '(#:phases
+ (alist-replace
+ 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (let ((inner
+ (substring source
+ (string-index-right source #\k)
+ (string-index-right source #\-))))
(and (zero? (system* "tar" "xvf" source))
(zero? (system* "tar" "xvf" (string-append inner ".tar.gz")))
(chdir inner)
(chdir "src"))))
- (alist-replace
- 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (let ((perl (assoc-ref inputs "perl"))
- (check (assoc-ref %standard-phases 'check)))
- (substitute* "plugins/kdb/db2/libdb2/test/run.test"
- (("/bin/cat") (string-append perl "/bin/perl")))
- (substitute* "plugins/kdb/db2/libdb2/test/run.test"
- (("D/bin/sh") (string-append "D" (which "bash"))))
- (substitute* "plugins/kdb/db2/libdb2/test/run.test"
- (("bindir=/bin/.") (string-append "bindir=" perl "/bin")))
- ;; use existing files and directories in test
- (substitute* "tests/resolve/Makefile"
- (("-p telnet") "-p 23"))
- ;; avoid service names since /etc/services is unavailable
- (apply check args)))
- %standard-phases)))))
+ (alist-replace
+ 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let ((perl (assoc-ref inputs "perl"))
+ (check (assoc-ref %standard-phases 'check)))
+ (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+ (("/bin/cat") (string-append perl "/bin/perl")))
+ (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+ (("D/bin/sh") (string-append "D" (which "bash"))))
+ (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+ (("bindir=/bin/.") (string-append "bindir=" perl "/bin")))
+ ;; use existing files and directories in test
+ (substitute* "tests/resolve/Makefile"
+ (("-p telnet") "-p 23"))
+ ;; avoid service names since /etc/services is unavailable
+ (apply check args)))
+ %standard-phases))))
(synopsis "MIT Kerberos 5")
(description
"Massachusetts Institute of Technology implementation of Kerberos.
diff --git a/gnu/packages/openssl.scm b/gnu/packages/openssl.scm
index 2af24abe4a..ca72aa804e 100644
--- a/gnu/packages/openssl.scm
+++ b/gnu/packages/openssl.scm
@@ -37,30 +37,29 @@
(build-system gnu-build-system)
(inputs `(("perl" ,perl)))
(arguments
- (lambda (system)
- `(#:parallel-build? #f
- #:parallel-tests? #f
- #:test-target "test"
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "./config"
- "shared" ; build shared libraries
- "--libdir=lib"
- (string-append "--prefix=" out)))))
- (alist-cons-before
- 'patch-source-shebangs 'patch-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* (find-files "test" ".*")
- (("/bin/sh")
- (string-append bash "/bin/bash"))
- (("/bin/rm")
- "rm"))))
- %standard-phases)))))
+ '(#:parallel-build? #f
+ #:parallel-tests? #f
+ #:test-target "test"
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero?
+ (system* "./config"
+ "shared" ; build shared libraries
+ "--libdir=lib"
+ (string-append "--prefix=" out)))))
+ (alist-cons-before
+ 'patch-source-shebangs 'patch-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* (find-files "test" ".*")
+ (("/bin/sh")
+ (string-append bash "/bin/bash"))
+ (("/bin/rm")
+ "rm"))))
+ %standard-phases))))
(synopsis "OpenSSL, an SSL/TLS implementation")
(description
"OpenSSL is an implementation of SSL/TLS")
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a37202b7bb..5d5b7ac099 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -38,32 +38,31 @@
"15qxzba3a50c9nik5ydgyfp62x7h9vxxn12yd1jgl93hb1wj96km"))))
(build-system gnu-build-system)
(arguments
- (lambda (system)
- `(#:tests? #f
- #:patches (list (assoc-ref %build-inputs "patch/no-sys-dirs"))
- #:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (libc (assoc-ref inputs "libc")))
- ;; Use the right path for `pwd'.
- (substitute* "dist/Cwd/Cwd.pm"
- (("/bin/pwd")
- (which "pwd")))
+ '(#:tests? #f
+ #:patches (list (assoc-ref %build-inputs "patch/no-sys-dirs"))
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (libc (assoc-ref inputs "libc")))
+ ;; Use the right path for `pwd'.
+ (substitute* "dist/Cwd/Cwd.pm"
+ (("/bin/pwd")
+ (which "pwd")))
- (zero?
- (system* "./Configure"
- (string-append "-Dprefix=" out)
- (string-append "-Dman1dir=" out "/share/man/man1")
- (string-append "-Dman3dir=" out "/share/man/man3")
- "-de" "-Dcc=gcc"
- "-Uinstallusrbinperl"
- "-Dinstallstyle=lib/perl5"
- "-Duseshrplib"
- (string-append "-Dlocincpth=" libc "/include")
- (string-append "-Dloclibpth=" libc "/lib")))))
- %standard-phases))))
+ (zero?
+ (system* "./Configure"
+ (string-append "-Dprefix=" out)
+ (string-append "-Dman1dir=" out "/share/man/man1")
+ (string-append "-Dman3dir=" out "/share/man/man3")
+ "-de" "-Dcc=gcc"
+ "-Uinstallusrbinperl"
+ "-Dinstallstyle=lib/perl5"
+ "-Duseshrplib"
+ (string-append "-Dlocincpth=" libc "/include")
+ (string-append "-Dloclibpth=" libc "/lib")))))
+ %standard-phases)))
(inputs `(("patch/no-sys-dirs" ,(search-patch "perl-no-sys-dirs.patch"))))
(synopsis "Implementation of the Perl programming language")
(description