aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-29 14:51:51 +0800
committer宋文武 <iyzsong@gmail.com>2015-08-29 15:07:54 +0800
commit122d0d10c63acbfe5c32b8424691868427a767b5 (patch)
tree594deb1b759525c721dd29f291ed00665fdb627d /gnu
parentde3d612a525223d3bec2ad182cdfd97cb5d4624d (diff)
downloadguix-122d0d10c63acbfe5c32b8424691868427a767b5.tar
guix-122d0d10c63acbfe5c32b8424691868427a767b5.tar.gz
gnu: Add yelp-tools.
* gnu/packages/gnome.scm (yelp-tools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8d66ed35fc..f874414582 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3430,3 +3430,34 @@ to format Docbook and Mallard documents.")
man, info, and HTML documents. It can locate documents according to the
freedesktop.org help system specification.")
(license license:gpl2+)))
+
+(define-public yelp-tools
+ (package
+ (name "yelp-tools")
+ (version "3.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "177qzvj5w019isdp41qxqcys2kc4sq2x6dqhqn6l9ipib8a6rxml"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; Needed by `yelp-build', `yelp-check' or 'yelp.m4'.
+ `(("itstool" ,itstool)
+ ("xmllint" ,libxml2)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("yelp-xsl" ,yelp-xsl)))
+ (home-page "https://wiki.gnome.org/Apps/Yelp/Tools")
+ (synopsis "Yelp documentation tools")
+ (description
+ "Yelp-tools is a collection of scripts and build utilities to help create,
+manage, and publish documentation for Yelp and the web. Most of the heavy
+lifting is done by packages like yelp-xsl and itstool. This package just
+wraps things up in a developer-friendly way.")
+ (license license:gpl2+)))