aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-01 01:55:37 -0500
committerMark H Weaver <mhw@netris.org>2015-01-01 02:30:46 -0500
commit0f481f0616ee3688d616ce49f2973a1ca958d73f (patch)
treef7b6e28dde01aef6c582de34f75cd4c990b0cebc /gnu
parent171bf17cc5bdf3b8421c0ce6540921fc77b1e2bd (diff)
downloadguix-0f481f0616ee3688d616ce49f2973a1ca958d73f.tar
guix-0f481f0616ee3688d616ce49f2973a1ca958d73f.tar.gz
gnu: mesa: Fix build on non-intel systems.
* gnu/packages/gl.scm (mesa): On non-intel systems, pass "--with-dri-drivers=" configure flag with i915 and i965 removed.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gl.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 791b413da6..aa90c7e214 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -20,6 +20,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gl)
+ #:use-module (ice-9 match)
#:use-module ((guix licenses) #:prefix l:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -161,9 +162,17 @@ Polygon meshes, and Extruded polygon meshes")
("python" ,python-2))) ; incompatible with Python 3 (print syntax)
(arguments
`(#:configure-flags
- `(;; drop r300 from default gallium drivers, as it requires llvm
+ '(;; drop r300 from default gallium drivers, as it requires llvm
"--with-gallium-drivers=r600,svga,swrast"
- "--enable-xa")
+ "--enable-xa"
+
+ ;; on non-intel systems, drop i915 and i965
+ ;; from the default dri drivers
+ ,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ '())
+ (_
+ '("--with-dri-drivers=nouveau,r200,radeon,swrast"))))
#:phases (alist-cons-after
'unpack 'add-missing-m4-files
(lambda _