aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-16 21:50:51 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:15 +0200
commit0e881505f19bd9ea9eb543c43483f2ac45a912b3 (patch)
tree51b809280e7e7754448cdb8a4b676247686ac44f /gnu
parent29d5767343565b557d796107fa699affca107bda (diff)
downloadguix-0e881505f19bd9ea9eb543c43483f2ac45a912b3.tar
guix-0e881505f19bd9ea9eb543c43483f2ac45a912b3.tar.gz
gnu: make-libstdc++: Adjust order of phases.
* gnu/packages/gcc.scm (make-libstdc++)[arguments]: Move custom 'fix-rs6000-libdir phase to after the 'unpack phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c39332b349..fb1dda36b3 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1006,7 +1006,7 @@ using compilers other than GCC."
(assoc-ref inputs "powerpc64le-patch"))))))
'()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
- (add-before 'chdir 'fix-rs6000-libdir
+ (add-after 'unpack 'fix-rs6000-libdir
(lambda _
(when (file-exists? "gcc/config/rs6000")
(substitute* (find-files "gcc/config/rs6000")